AJAX - Publicar ajax en la web medium trust

   
Vista:

Publicar ajax en la web medium trust

Publicado por galo recalde (1 intervención) el 14/11/2007 18:48:00
Hola necesito una ayuda, necesito saber como configurar el web config, para la libreria ajaxpro Version 7.7.31.1, este es mi web config
<?xml version="1.0"?>
<configuration>

<configSections>

<sectionGroup name="ajaxNet">

<section name="ajaxSettings"
type="AjaxPro.AjaxSettingsSectionHandler,AjaxPro.2" restartOnExternalChanges="true"/>
</sectionGroup>
<section name="infragistics.web" type="System.Configuration.SingleTagSectionHandler,System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
</configSections>
<appSettings/>
<connectionStrings>
<add name="ConnectionString" connectionString="Dsn=sudepro_NeoWeb;uid=sudepro_bdNeo;pwd=123123123" providerName="System.Data.Odbc"/>
</connectionStrings>

<ajaxNet>
<ajaxSettings>
<urlNamespaceMappings useAssemblyQualifiedName="false" allowListOnly="false"> </urlNamespaceMappings>
<jsonConverters includeTypeProperty="true"></jsonConverters>
<debug enabled="false" />
<token enabled="false" sitePassword="password" />
</ajaxSettings>
</ajaxNet>






<system.web>
<compilation debug="true">
<assemblies>
<add assembly="Infragistics2.WebUI.UltraWebGrid.v7.2, Version=7.2.20072.61, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
<add assembly="Infragistics2.WebUI.Shared.v7.2, Version=7.2.20072.61, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
<add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="Infragistics2.WebUI.Misc.v7.2, Version=7.2.20072.61, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
<add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<!-- <add assembly="AjaxPro.AjaxHandlerFactory,AjaxPro.2, Version=7.7.31.1, Culture=neutral,PublicKeyToken=4735ae9824c7d3ec"/>-->
</assemblies>
</compilation>

<authentication mode="Windows"/>
</system.web>
<location path="ajaxpro">
<system.web>
<httpModules>
<add name="SubgurimSiteMapContextRequest" type="Subgurim.Controles.SSM.SubgurimSiteMapContextRequest"/>
</httpModules>
<httpHandlers>
<add verb="*" path="/_vti_bin/*.aspx" type="AjaxPro.AjaxHandlerFactory, AjaxPro, Version=6.7.20.1, Culture=neutral, PublicKeyToken=4735ae9824c7d3ec"/>
<add verb="*" path="*.aspx" type="Microsoft.SharePoint.ApplicationRuntime.SharePointHandlerFactory, Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"/>
<add verb="*" path="*.ashx" type="AjaxPro.AjaxHandlerFactory,AjaxPro.2, Version=7.7.31.1, Culture=neutral,PublicKeyToken=4735ae9824c7d3ec"/>

</httpHandlers>
</system.web>
</location>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.vl">
<dependentAssembly>
<assemblyIdentity name="Infragistics2.WebUI.UltraWebTab.v7.2 " publicKeyToken="7DD5C3163F2CD0CB "/>
<bindingRedirect oldVersion="6.2.20062.1-7.2.20072.61 " newVersion="7.2.20072.61 "/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Infragistics2.WebUI.Shared.v7.2 " publicKeyToken="7DD5C3163F2CD0CB "/>
<bindingRedirect oldVersion="6.2.20062.1-7.2.20072.61 " newVersion="7.2.20072.61 "/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Infragistics2.WebUI.UltraWebGrid.v7.2 " publicKeyToken="7DD5C3163F2CD0CB "/>
<bindingRedirect oldVersion="6.2.20062.1-7.2.20072.61 " newVersion="7.2.20072.61 "/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Infragistics2.WebUI.WebCombo.v7.2 " publicKeyToken="7DD5C3163F2CD0CB "/>
<bindingRedirect oldVersion="6.2.20062.1-7.2.20072.61 " newVersion="7.2.20072.61 "/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="AjaxPro.AjaxHandlerFactory.v7.7.31.1" PublicKeyToken="4735ae9824c7d3ec"/>
<bindingRedirect oldVersion="6.2.20062.1-7.2.20072.61 " newVersion="7.2.20072.61 "/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de AJAX
- Código fuente de AJAX
- Cursos de AJAX
- Temas de AJAX
información
Códigos de AJAX
- Editor para pagina Web
- Actualizar desplegable
- Autocompletar

RE:Publicar ajax en la web medium trust

Publicado por Fernando (1 intervención) el 17/11/2007 11:33:48
Disculpá, no es una respuesta a tu pregunta, si no una pregunta para vos. Veo q usás el ultrawebgrid de infragistics. Nunca usé AJAX, tengo una grilla ultrawebgrid con un botón en cada fila para eliminar esa fila, pero me piden que pida confirmación antes de borrar el registro. O sea, tendría q hacerlo para cada botón de la columna de botones, sabés si es eso posible? lo has hecho antes? muchas gracias. Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Publicar ajax en la web medium trust

Publicado por Manuel Zambrano (1 intervención) el 27/01/2009 17:38:54
Lo unico que tienes que hacer es colocar este codigo dentro de la etiqueta "<system.web> </system.web>" y listo...

<httpHandlers>
<add verb=“POST,GET“
path=“ajaxpro/*.ashx”
type=“AjaxPro.AjaxHandlerFactory,AjaxPro.2“/>
</httpHandlers>
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar