ASP.NET - Load report failed. en IIS

   
Vista:

Load report failed. en IIS

Publicado por Zephir (18 intervenciones) el 30/04/2009 13:23:55
Hola Amigos;

Tengo un problema a la hora de publicar un proyecto en ASP.NET que hace uso de Crystal Reports.

En mi máquina de desarrollo el crystal se muestra correctamente.

Sencillamente creo un CrystalReportViewer, en la propiedad reportsource le asigno un CrystalReportSource que tiene como report.filename el fichero rpt.

En mi máquina de desarrollo esto esta funcionando correctamente, pero la hora de publicarlo en el IIS de producción me encuentro con un mensaje que dice: "Load report failed."

He probado con diferentes rutas y con la función server.mappath y nada... en desarrollo cargan y en el IIS no.

Gracias por la ayuda
Zephir
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Load report failed. en IIS

Publicado por Javi (2 intervenciones) el 30/04/2009 16:18:39
En el servidor IIS tienes instalado crystal?

Puedes describir exactamente que error te devuelve?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Load report failed. en IIS

Publicado por Zephir (18 intervenciones) el 04/05/2009 09:28:43
Buenas;

En el servidor tengo instalado visual studio 2005. Y Crystal Reports viene por defecto con la instalación en una versión reducida (no la completa de business objects).

He observado lo siguiente:

si en mi web.config tengo la etiqueta <identity impersonate="true" /> el crystal no se carga. En cambio si la quito este carga bien.

Por motivos de base de datos la etiqueta debe existir, ya que si esta no existe no tengo conexión a la base de datos.

El error en si mismo no lanza una excepcion que se deba controlar, sólo muestra un mensaje en pantalla que dice "Load report failed".

Gracias
Z.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Load report failed. en IIS

Publicado por Cronos (1 intervención) el 19/09/2009 02:36:15
Saludos no se, si ya resolviste este problema

Pero va me encontre q desarrollo una aplicacion web q se ve atravez de internet
y me encotre el horrible error load repor falide como la mayoria de los q lean este post me encontre N cantidad que decian que puede ser la seguridad en el iis que la ruto no es valida ok
Como lo solucione
inserte un objeto CrystalReporViewer y en el souce le inserte la ruta fisica
de donde se encuentra el reporte
listo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar