ASP.NET - Framework 3.5 y 2.0

   
Vista:

Framework 3.5 y 2.0

Publicado por Thanatos (1 intervención) el 05/03/2010 21:58:22
Buenas buenas,

Ante todo agradezco el haber leído mi consulta. Mi problema es el siguiente:

Desarrolle un website para una empresa x, este fue desarrollado con visual studio 2008, con c# y bajo el framework 3.5. Al publicar e iniciar en el servidor(el de la empresa x), me genero unos errores, investigue sobre esto y encontre que era por que ese servidor no tenia el framework 3.5 instalado. Una de mis sorpresas, fue el saber que el servidor de esta empresa esta bajo windows server 2000; la segunda fue el saber que este SO no es compatible con el W2000.

Una de las soluciones que encontre, fue pasar las librerias necesarias como referencia al bin del proyecto, pero esto no me es posible, ya que los componentes que necesito son MSIL, y estan en el GAC.

Intente convertirlos a dll, por medio de la herramienta "Ilasm", si exito alguno, y segun lei por la red, esta herramienta no genera dll desde la GAC.

Hay alguna forma de convertir esto a libreria? Me podrian facilitar un ejemplo? Hay alguna otra solucion posible?

No puedo cambiar el framework a la website, es decir, pasarla a 2.0, porque me genera varios errores que no he podido tratar. Entre ellos esta:

Error El tipo o el nombre del espacio de nombres 'Linq' no existe en el espacio de nombres 'System' (¿falta una referencia de ensamblado?)

Al comentar el importe de este namespace, me aparecen mas errore4s, del tipo:

Etiqueta de servidor 'asp:ScriptManager' desconocida.

Lo que necesito convertir a dll:

System.Web.Extensions
Microsoft.ReportViewer.WebForms

Espero alguien me pueda colaborar con esto, ya que es urgente(Siempre lo es para el cliente) Agradezco de antemano toda su colaboracion.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Framework 3.5 y 2.0

Publicado por m (121 intervenciones) el 06/03/2010 00:28:03
Pues lo siento, no es posible trabajar con el Framwork a 3.5 y 2k server , deberas actualizar el servidor a 2003 o 2008.

saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de roger

RE:Framework 3.5 y 2.0

Publicado por roger (311 intervenciones) el 06/03/2010 02:39:03
busca el nombre de la dll en google, seguro la debes encontrar, ejemplo :
http://support.microsoft.com/kb/933137

Si no es esta, puedes continuar la busqueda, pues si no utilizas ninguna funcionalidad del framework 3.5 no debes tener problema en pasar a la 2.0. Por ejemplo el error que muestras es porque en el codigo tendras using (imports de visual basic .net) a System.Linq, pues se crean por defecto al haber elegido el framework 3.5 para trabajar. Pero es cuestion de reemplazar donde haya este using por vacio y ya, y asi vas deshaciendote de cada error que te salga

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Framework 3.5 y 2.0

Publicado por Thanatos (1 intervención) el 08/03/2010 15:21:53
Buen día,

Muchas gracias a aquellos que se tomaron el tiempo para leer mi duda, agradezco las soluciones planteadas.

Cierro el tema debido a que el cliente tomo la decisión de adquirir un nuevo servidor, y montar en el un windows server 2003! (Cuantos desarrolladores nos damos ese lujo de cliente?? :-P )

Muchas gracias y hasta luego!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Framework 3.5 y 2.0

Publicado por Khristian (335 intervenciones) el 13/03/2010 13:03:02
Los desarrolladores con "miras" al futuro lo hacen.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar