ASP.NET - PORQUE MOZILLA NO HACE NADA?

   
Vista:

PORQUE MOZILLA NO HACE NADA?

Publicado por ANTONIO (105 intervenciones) el 16/05/2008 11:52:33
Hola amigos el codigo que tengo puesto abajo lo coloco en el evento load del formulario y funciona de maravilla con internet explorer es decir al hacer click en el imagebutton si el control A1 esta desabilitado me abre una pagina y si esta habilitado me abre otra pagina y funciona correcto. Pero cual fue mi sorpresa que cuando esto mismo lo pruebo con el mozilla firefox entonces no hace nada de nada no sale ningun error pero no funciona, mirando y probando el codigo me di cuenta de que si al pedazo de codigo disabled==false le quito un "= " y lo dejo disabled=false entonces en mozilla si que me abre una pagina pero siempre me abre la misma independientemente de si disabled=true o false.
En fin amigos echar un vistazo a ver si esque en mozilla esto se hace de otra forma o la verdad estoy desquiciado porque no se que puede ser.
Saludos cordiales amigos.

ImageButton1.Attributes.Add("onclick", "if(document.getElementById('A1').disabled==false){win=window.open('blogclub.aspx','blog','resizable=yes');return false;} else if(document.getElementById('A1').disabled==true) {win = window.open('nosocio.aspx', 'socios','resizable=yes,width=800,height=400');return false;}")
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:PORQUE MOZILLA NO HACE NADA?

Publicado por Khristian (335 intervenciones) el 17/05/2008 02:49:09
Por lo que veo.... el link de la pagina que hay que abrir depende del estado del imagebutton.

Porque cuando el imagebutton cambie de estado, no cambias la URL del link ???

Lo otro.... hazlo en el servidor, no en el cliente

If Control.Enabled then
IR -> response.redirect(URL1)
else
IR -> response.redirect(URL 2)
endif


saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:PORQUE MOZILLA NO HACE NADA?

Publicado por ANTONIO (105 intervenciones) el 17/05/2008 10:39:13
GRACIAS KHRISTIAN EFECTIVAMENTE PUEDO HACERLO DE LADO DEL SERVIDOR PERO ENTONCES AL HACERLO ASI ME TARDA MUCHO MAS SE RECARGA TODO Y DE LADO CLIENTE VA MAS RAPIDO Y SE VE MAS PROFESIONAL.
LO QUE ME GUSTARIA AVERIGUAR ES EL "POR QUE" CON MOZILLA NO FUNCIONA YA QUE TEORICAMENTE DEBERIA DE FUNCIONAR Y NO SE PORQUE LECHES NO VA.
MUCHAS GRACIAS POR TU RESPUESTA AMIGO.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar