ASP - Problema al cargar datos de una base de datos

   
Vista:

Problema al cargar datos de una base de datos

Publicado por David Reyes (1 intervención) el 15/08/2008 14:34:31
Hola a todos, tengo el siguiente problema y la verdad me urge dar solucion pero no he podido.

Tengo una pagina en asp, en la que hago un select para consultar datos de una base de datos SQL, cuando en dreamweaver hago una tabla dinamica me muestra todos los datos, pero intento modificar la tabla unicamente, es decir darle la forma, presentacion a la tabla, ahi ya no puedo mostrar todos los datos, solo unos se dejan ver y no entiendo que pasa.

Tambien tengo este codigo:

<%@LANGUAGE="VBSCRIPT" CODEPAGE="1252"%>
<!--#include file="Connections/inventarios.asp" -->
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Documento sin título</title>
</head>
<body>
<%
usuario = request.QueryString("us")
Dim Recordset1
Dim Recordset1_numRows
Set Recordset1 = Server.CreateObject("ADODB.Recordset")
Recordset1.ActiveConnection = MM_inventarios_STRING
Recordset1.Source = "SELECT * FROM dbo.equipos where Usuario = '"& usuario &"' "
Recordset1.CursorType = 0
Recordset1.CursorLocation = 2
Recordset1.LockType = 1
Recordset1.Open()
Recordset1_numRows = 0

while NOT Recordset1.EOF

response.Write(Recordset1.Fields.Item("Antivirus") .value) ' lo muestra
response.Write(Recordset1.Fields.Item("Departament o").value) 'no lo muestra
response.Write(Recordset1.Fields.Item("Dir_ip").va lue) ' lo muestra
response.Write(Recordset1.Fields.Item("Disco").val ue) ' lo muestra

response.Write(Recordset1.Fields.Item("Cpu").value ) ' lo muestra
Recordset1.movenext()
wend

%>

</body>
</html>
<%
Recordset1.Close()
Set Recordset1 = Nothing
%>

Si se dan cuenta aparentemente esta bien, pero me muestra solamente unos datos, no todos los 5 datos que estoy intentando mostrar, ahi lo tengo que while, pero ni con if funciona.

Que puede estar pasando?? porque no puedo mostrar todos los datos???

Por favor, ruego por ayuda, es urgente esto.

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema al cargar datos de una base de datos

Publicado por weirdmix (210 intervenciones) el 15/08/2008 19:31:28
el primer error q tienes es hacer un select * ... debes de escribir los campos aunque te de flojera...
el segundo error es el cursor.location=2, lo deberias poner en 3, es decir, en el cliente...
el tercer error es Recordset1_numRows = 0, eso q significa? conozco Recordset1.recordcount pero no como lo indicas...

saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar