Access - Fallo en stlinkcriteria

   
Vista:

Fallo en stlinkcriteria

Publicado por Ivi (3 intervenciones) el 02/09/2009 13:52:40
Tengo dos tablas con sus correspondientes formularios:
tbEstado_Legal y tbPropietario y sus correspondientes formularios las dos con un campo com├║n [n┬║ registro] y una relaci├│n 1 a 1

el c├│digo que emple├ę es este:

-------------------------------
Private Sub CmdfmrPropietario_Click()
On Error GoTo Err_CmdfmrPropietario_Click

Dim stDocName As String
Dim stLinkCriteria As String

stDocName = "fmrPropietario"

stLinkCriteria = "[n┬║ registro]=" & "'" & Me![n┬║ registro] & "'"
DoCmd.OpenForm stDocName, , , stLinkCriteria

Exit_CmdfmrPropietario_Click:
Exit Sub

Err_CmdfmrPropietario_Click:
MsgBox Err.Description
Resume Exit_Cmdfmrpropietario_Click

End Sub
-----------------------------------
El campo [nº registro] es de texto con una máscara de entrada de letras un números.

Gracias antes de nada
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Fallo en stlinkcriteria

Publicado por Jefferson (1 intervenci├│n) el 02/09/2009 15:15:21
Hola Ivi

Sin Tanto codigo

Private Sub CmdfmrPropietario_Click()
DoCmd.OpenForm "fmrPropietario", , , "[n┬║ registro]= '" & Me![n┬║ registro] & "'"
End Sub

Por Cierto el error estaba aqui
("[n┬║ registro]=" & "'" & Me![n┬║ registro] & "'" ) .. "& ????

Desde Venezuela
Jefferson
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Fallo en stlinkcriteria

Publicado por dado (5 intervenciones) el 02/09/2009 21:33:38
revisa el linnk
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar