Access - Problemas con los botones de enlace entre form

   
Vista:
Imágen de perfil de Silvia

Problemas con los botones de enlace entre form

Publicado por Silvia silvia.kern@gmail.com (5 intervenciones) el 05/09/2013 13:18:13
Hola... mi problema es el siguiente: pongamosla fácil, una tabla empleados, clave legajo. Una tabla hijos de empleados, clave legajo. Formulario empleado muestra datos de empleados, form hijos muestra listado de hijos. En el form empleados pongo un boton que al clic muestre SOLO los hijos de ese empleado (fácil, misma clave, mismo formato, enlace directo). Nada, no hay forma. En los casos en que el boton anda, muestra toda la tabla hijos, no consigo que filtre por clave. Por favor, es urgente tengo todo desconfigurado me quieren matar !! GRacias. (2007 - ya toqué la configuracion de macros, tiene todo habilitado)
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problemas con los botones de enlace entre form

Publicado por Jesús Manuel (134 intervenciones) el 06/09/2013 12:22:06
Pongamos que el ID1 es el que tienes en la tabla de empleados y el ID2 es el que tienes en la tabla de hijos y que hace referencia a los empleados (para crear la relación 1 a infinito). Tienes que montar la relación en la ventana de relaciones entre las dos tablas por estos campos.

Si insertas un nuevo botón en el formulario empleados ya salta el asistente y vas a OPERACIONES CON FORUMULARIOS y ABRIR FORMULARIO. Indicas el formulario que quieres abrir (hijos) y ABRIR FROM, luego BUSCAR DATOS ESPECÍFICOS. Aquí ya puedes indicar que enlace por ID1 e ID2. Luego ya solo queda elegir entre un texto o una imagen y el nombre para el botón.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de silvia

Problemas con los botones de enlace entre form

Publicado por silvia silvia.kern@gmail.com (5 intervenciones) el 06/09/2013 12:31:13
SI, están hechos así, pero apretás el botón y muestra toda la base ID2. No filtra nada, ni siquiera se posiciona, nada. Lo probé con varias tablas, varias bases diferentes, cambié configuracion, cambie centro de confianza, usé ID autonuméricos en la ID1, ya no sé mas ... se me terminaron las opciones y NO ANDA !!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Problemas con los botones de enlace entre form

Publicado por Jesús Manuel (134 intervenciones) el 06/09/2013 13:30:51
Intentalo por código VBA:

Inserta un botón en el formulario de empleados y cancela es asistente.
En las propiedades del botón, EVENTOS, AL HACER CLIC, GENERADOR DE CÓDIGO y pegas lo siguiente:


DoCmd.OpenForm "Nombre_Formulario_Hijos", acNormal, , "[ID2]=" & Me![ID1]


ID2 es el que esta en el formulario de hijos e ID1 es el que esta en el formulario de empleados

Pon el nombre de tu formulario hijos adecuado
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de SILVIA

Problemas con los botones de enlace entre form

Publicado por SILVIA (5 intervenciones) el 06/09/2013 17:40:16
Gracias... así anda, ahora por qué no lo hace con el generador automático ??? algo está desconfigurado ???
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar