Access - error en informe al no cargar subinforme

   
Vista:

error en informe al no cargar subinforme

Publicado por Arathons21 (1 intervención) el 03/10/2014 07:50:10
Hola todos, espero alguien me ayude con el siguiente problema

Tengo un informe que carga los datos de una consulta llamada cargas donde el criterio es el idchofer que a su ves toma el valor de un formulario llamado pagos . ejemplo: [Forms]![pagos]![idchofer] tengo un subinforme que a su ves toma los datos de una consulta llamada gastos x carga que usa como criterio el valor del mismo formulario. ejemplo: [Forms]![pagos]![idchofer] y otro subinforme que toma los mismos datos que estos de una consulta llamada adelantos pago con el mismo criterio y tomando el valor del mismo formulario pero cuando un chofer no tiene adelantos o gastos el informe padre me da error ya que no carga los subinformes al estar estos vacios. en vista reporte se ve bien pero en vista previa o al exportarlo a pdf me muestra el error. en el pie del informe padre tengo los campos calculados de la siguiente forma :

= [payment miles] + [gastos].Report![total gastos] - [adelantos pago].Report![total adelantos]

donde payment miles es el total de millas* precio x milla y total gastos es la suma de todos los gastos en el subinforme gastos y total adelantos es el total de la suma de adelantos en el subinforme adelantos

alguien sabe como puedo corregir este error.

desde ya muchisimas graciasssssss x adelantado porque me tiene loco este error ya
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder