Algoritmia - algoritmo 3

   
Vista:

algoritmo 3

Publicado por omar david camargo zuleta (2 intervenciones) el 20/09/2009 19:35:43
de una lista de 100 numeros determinar simultaneamente el maximo y minimo numero.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:algoritmo 3

Publicado por eduardo (55 intervenciones) el 21/09/2009 19:07:50
Var
entero: i
entero: lista[100], menor, mayor

Inicio
Leer( lista )
menor = menor = lista[0]
Desde i = 1 hasta i < 100 inc i++ hacer
Si ( lista[i] < menor ) entonces
menor = lista[i]
Fin si

Si ( lista[i] > mayor ) entonces
mayor = lista[i]
Fin si
Fin desde

Escribir( "Menor: " + menor )
Escribir( "Mayor: " + mayor );
Fin

Esto si los datos se encuentran almacenados ya en el vector "lista". Ahora si tiene que determinarse el menor y mayor durante el proceso de lectura de los elementos pues es similar, solo que esta vez se debe leer el primer elemento del vector fuera del bucle.

Inicio
i = 0
Leer( lista[i] )
menor = mayor = lista[i]
desde i = 1 hasta i < 100 inc i++ hacer
Leer( lista[i] )
Si ( lista[i] < menor ) entonces
menor = lista[i]
Fin si

Si ( lista[i] > mayor ) entonces
mayor = lista[i]
Fin si
Fin desde

Escribir( "Menor: " + menor )
Escribir( "Mayor: " + mayor );
Fin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:algoritmo 3

Publicado por iscar zabaleta (3 intervenciones) el 07/12/2009 22:20:13
khushdsgf
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar