Algoritmia - resolver en estructuras simple , doble y anidada

   
Vista:

resolver en estructuras simple , doble y anidada

Publicado por karla fabiola (1 intervención) el 24/09/2009 08:48:14
URGENTE

PARA EL DIA JUEVES 24 DE SAPTIEMBRE

SE LO AGRADECEDIA MUCHISSIMO

RESOLVER ESTE PROBLEMA POR UNA DE LAS ESTRUCTURAS DOBLE , SIMPLE, ANIDADA Y MULTIPLE.

RESOLVER EL PROBLEMA CON LA ESTRUCTURA MAS ADECUADA.

1.- Elabore un algoritmo que calcule los importes por concepto de renta, el impuesto y el costo total de una llamada telefónica de larga distancia de acuerdo a lo siguiente: Los 3 primeros minutos tienen un determinado costo. Los minutos que sobrepasen a 3 y no excedan a 10 su costo se incrementas a un 12% y Los minutos que excedan a 10 su precio se incrementa en un 18% sobre el precio de los minutos iniciales. El tiempo mínimo que se cobra por una llamada es de 3 minutos. Solo se cobran minutos completos (es decir si la llamada fue de 4.2 minutos se le cobran 5, si fue de 1.3 se le cobran 2), A cada llamada se le cobra un % de renta sobre lo que resulte se le cobra un % de impuestos
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:resolver en estructuras simple , doble y anidad

Publicado por eduardo (55 intervenciones) el 24/09/2009 16:08:55
Es sencillo, parecido a uno de nómina que vi en un libro de Joyanes Aguilar.

Var
Const Real: costoMin = COSTO_MINUTO
Const Real: igv = PORCENT_IGV
Real: fMin
Entero: iMin
Real: subTotal, impuestos, total, igv

Inicio
Leer( fMin )
Si ( (Real)truncar(fMin) < fMin ) entonces
....iMin = truncar( fMin + 1)
sino
....iMin = (Entero)fMin
Fin si

Si ( iMin > 3 ) entonces
....Si ( iMin <= 10 ) entonces
........subTotal = 3 * costoMin + ( iMin - 3 ) * costoMin * 1.12
....sino
........subTotal = 3 * costoMin + 7 * costoMin * 1.12 + ( iMin - 10 ) * costoMin * 1.18
....Fin si
sino Si ( iMin > 0 )
....Imin = 3
....subTotal = iMin * costoMin
sino
....subTotal = 0
Fin si

impuestos = subTotal * igv * 0.01
total = subTotal + impuestos

Escribir( "Sub -Total : " + subTotal )
Escribir( "Impuestos : " + impuestos )
Escribir( "Total : " + total )

Fin

Ahí tienes tu tareíta men
Salu2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

sorry

Publicado por eduardo (55 intervenciones) el 24/09/2009 16:12:00
Sorry men no, woman :P
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar