Algoritmia - necesito un algoritmo que me ayude a saber que si

   
Vista:

necesito un algoritmo que me ayude a saber que si

Publicado por stephanie (1 intervención) el 15/02/2010 23:36:23
necesito saber cual es el algoritmo por el cual pueda saber que tipo de signo soy y ademas que lo pueda utilisar con otras personas
GRACIAAAAAAAAAAAAAAAAASSSSSSSSSS.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Algoritmia
- Cursos de Algoritmia
- Temas de Algoritmia
- Chat de Algoritmia
información
Cursos y Temas de Algoritmia
- Curso de Metodología
- Entendiendo la Recursividad
- Algoritmos de Ordenación

RE:necesito un algoritmo que me ayude a saber que

Publicado por George (2 intervenciones) el 12/03/2010 18:13:12
Hola stephanie es fácil debes controlar sólo los rangos de fechas.

es decir si sos mayor a tal fecha y menor a otra, será tu signo

Debes utilizar una estructura de desición multiple:
ejemplo:

segun fecha hacer

fecha > unaFecha y fecha < otrFecha
signo
fecha > unaFecha y fecha < otrFecha
signo **Signo segun la fecha de nacimiento, que pertenezca a ese signo

fin segun

Espero poder darte una idea.
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:necesito un algoritmo que me ayude a saber que

Publicado por Miguel Angel Maldonado (1 intervención) el 20/09/2010 17:26:46
Necesitas definir entre que intervalo de días se encuentra cada uno de los signos zodiacales, de manera que si (fecha => nacimiento)AND(fecha <= nacimiento) signo = un signo determinado dependiendo del intervalo...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:necesito un algoritmo que me ayude a saber que

Publicado por Ricardo Mendiola (1 intervención) el 22/09/2010 02:59:38
Solo necesitas poner de que fecha a que fecha es cada signo y ponerlos como condicion ejemplo:

if (fecha>=22/04) and (fecha<=21/05) then
mensaje "Geminis
else
if....

y asii con todos los signos del zodiaco..

suerte espero que te sirva!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:necesito un algoritmo que me ayude a saber que

Publicado por Marisol Oliváres (1 intervención) el 22/09/2010 17:14:56
mmmmmm
de hecho necesitas una condición más explicita, por ejemplo para Geminis sería:

if ((mes=4) and (dia>=22 or dia<=30)) then
mensaje "Geminis"
else
if (mes=5) and (dia>=1 or dia<=21)) then
mensaje "Geminis"
End

Y así sucesivamente con el resto de los signos del zodiaco.
Ojala y te sea de utilidad, considera que para cada lenguaje de programación cambia el código.
Bye
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:necesito un algoritmo que me ayude a saber que

Publicado por Estefania Villarreal (1 intervención) el 26/09/2010 22:10:23
Inicio
Escribir ("Ingresa el día en que naciste:");
Leer (d);
Escribir ("Ingresa el mes en que naciste en número:");
Leer (m);
En caso de m haga
caso 1: Si (d>0 & d<21) entonces Escribir ("Tu signo es Capricornio");
Si no(d>20 & d<32) entonces Escribir ("Tu signo es Acuario");
Si no entonces ("Este mes solo tiene 31 días"); Fin si

caso 2: Si (d>0 & d<20) entonces Escribir ("Tu signo es Acuario");
Si no(d>19 & d<30) entonces Escribir ("Tu signo es Piscis");
Si no entonces ("Este mes solo tiene 28 y 29 días"); Fin si

caso 3: Si (d>0 & d<21) entonces Escribir ("Tu signo es Piscis");
Si no(d>20 & d<32) entonces Escribir ("Tu signo es Aries");
Si no entonces ("Este mes solo tiene 31 días"); Fin si
etc..

Fin case
Fin

Espero que te sirva de algo XD
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar