Algoritmia - ayuda urgente con algoritmo

   
Vista:

ayuda urgente con algoritmo

Publicado por maxfire1989 (1 intervención) el 12/05/2010 22:15:40
Hola a todos necesito ayuda urgente espero me puedan ayudar trata de un taller de algoritmos el cual ya realice varios puntos pero ahy unos que no les puedo ayar la solucion

este es el taller :

click en la siguiente url para ver la imagen..

http://i42.tinypic.com/23lmoib.jpg

son 10 preguntas ya realice 6 el taller es para el jueves 13 de mayo de 2010 a la noche

espero me puedan ayudar

cualquier inquietud : n.g.z10@hotmail.com

Pd : las preguntas tachadas en negro ya estan resueltas por mi , solo me faltan los puntos : 4, 8 , 9 ,10

saludos comunidad espero puedan ayudar..
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:ayuda urgente con algoritmo

Publicado por Luis Guillermo Marquina (1 intervención) el 22/09/2010 17:54:13
Hola, por experiencia propia solo te puedo ayudar con este Pseudocodigo que resuelve la pregunta 4 ;)

Utilizas 3 variables: N
Suma
Indice

-Despues de que pidas el numero a calcular crea la siguiente condicion

Mientras (Indice<N) Hacer
Si(N ModIndice=0) Entonces Suma=Suma+Indice
Fin Si
Indice=Indice+1
Fin Mientras

Por lo tanto para saber si el numero es perfecto solo comparas N con la Suma

Si(N=Suma) Entonces Imprimir "Número Perfecto"
De lo contrario Imprimir "No es un Número Perfecto"
Fin Si

Espero haberte ayudado, poco, pero la intencion es lo que cuenta. XDD

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar