Algoritmia - TAREA DE ALGORITMOS

   
Vista:

TAREA DE ALGORITMOS

Publicado por EDUARDO (1 intervención) el 26/09/2011 21:54:22
OBTENER EL NUMERO DE LANZAMIENTOS DE UNA MONEDA HASTA LOGRAR 10 RESULTADOS SOL
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Algoritmia
- Cursos de Algoritmia
- Temas de Algoritmia
- Chat de Algoritmia
información
Cursos y Temas de Algoritmia
- Manual de algorítmica
- Colección de algoritmos de ordenación
- Teoría de Grafos
Imágen de perfil de Henry

TAREA DE ALGORITMOS

Publicado por Henry (5 intervenciones) el 30/09/2011 01:36:16
Buenas Eduardo
No se si ya resolviste el algoritmo, ahora es que estoy viendo tu mensaje. Tienes dos(2) ejemplos de algoritmo standar:

Inicio Programa
numero_lanzamientos = 0
lado_sol=0

Mientras (lado_sol sea menor a 10)
Lanzar moneda,lado
numero_lanzamientos=numero_lanzamientos+1
Si (lado es igual a sol)
lado_sol=lado_sol+1
Fin Si
Fin Mientras
Mostrar "Número de lanzamientos: " numero_lanzamientos
Fin Programa
--------------------------------------------------------------------------------------------------------------------------

Inicio Programa
numero_lanzamientos = 0
lado_sol=0

while (lado_sol < 10)
{
Lanzar moneda,lado
numero_lanzamientos=numero_lanzamientos+1
if (lado ="sol")
{
lado_sol=lado_sol+1
}
}
Mostrar "Número de lanzamientos: " numero_lanzamientos
Fin Programa

while (valor>=20) {
show valor
valor = valor + 1
if (valor==10) {
show "me gusta el 10"
}
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Henry

TAREA DE ALGORITMOS

Publicado por Henry (5 intervenciones) el 30/09/2011 01:38:17
Eduardo no tomes en cuenta esta codificación que se me coló:

while (valor>=20) {
show valor
valor = valor + 1
if (valor==10) {
show "me gusta el 10"
}
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar