Algoritmia - Calcular el factorial a m numeros

   
Vista:

Calcular el factorial a m numeros

Publicado por Jose (1 intervención) el 02/06/2012 05:47:31
Buenas amigos, apenas estoy empeazndo en esto de la informatica y lo que me piden es :

Escribir un programa que tome una cantidad m de valores ingresados por el usuario, a cada uno le calcule el factorial e imprima el resultado junto con el número de orden correspondiente.

lo que tengo en PSEINT es:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
Proceso factorial
	m<-0;num<-0;fact<-0
	Escribir "Ingrese la cantidad de números a calcular el factorial";
	Leer m;
	Para i<-1 Hasta m Hacer
		Escribir "Ingrese el valor-",i;
		Leer num
		fact<-1
		  Para i<-1 Hasta num Hacer
			fact<-fact*i
			Escribir "El factorial de-",num,"-es-",fact;
		  FinPara
	FinPara
FinProceso


------------------

lo que me hace es calcular solo el factorial de el ultimo numero :(
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Calcular el factorial a m numeros

Publicado por Juan Gaete juan.gaete@oracle.com (1 intervención) el 19/06/2012 15:37:21
Proceso factorial
m<-0;num<-0;fact<-1
Escribir "Ingrese la cantidad de números a calcular el factorial";
Leer m;
Para i<-1 Hasta m Hacer
Escribir "Ingrese el valor-",i;
Leer num
fact<-fact*num
Escribir "El factorial de-",num,"-es-",fact;
FinPara
FinProceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Calcular el factorial a m numeros

Publicado por Fernando (1 intervención) el 02/12/2014 00:57:05
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
yo lo mejore así:
 
Proceso Factorial
	definir n, num, fact, cont como real;
	n<-0;
	num<-0;
	fact<-1;
		Escribir "Ingrese un numero real";
		Leer n;
		Escribir "Los numeros enteros antes del numero ingresado son: ";
		Para cont<-1 Hasta n Hacer
			Escribir cont;
			num<-cont;
			fact<-fact*num;
 
		FinPara
		Escribir "El factorial de: ",num,"!"," es: ",fact;
	FinProceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar