Algoritmia - algoritmo en c++

   
Vista:

algoritmo en c++

Publicado por thael (1 intervención) el 03/04/2014 17:47:38
Para un empleado se tienen los siguientes datos:

Código del empleado (valor numérico).
Salario básico por hora.
Horas ordinarias trabajadas.
Horas extras trabajadas.
Elabore un algoritmo que calcule y muestre en pantalla:

Código del empleado.
Salario neto a pagar.
Valor de la retención en la fuente.
Tener en cuenta que las horas extras tienen un recargo del 40% y la retención en la fuente (10%) se aplica solo a las horas extras trabajadas, si el total obtenido por este concepto es superior a $100.000.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de bryan

algoritmo en c++

Publicado por bryan (3 intervenciones) el 04/04/2014 19:14:23
Proceso algortimo
Leer codigoTrab
Leer salarioBasico
Leer horasTrabajadas
Leer horasExtrasT
codigo <- codigoTrab
salario <- (salarioBasico*horasTrabajadas)
salarioExtra <- (horasExtrasT*salarioBasico)
salarioNeto <- (salario+salarioExtra)
Escribir codigo "codigo"
Escribir salario "salario"
Escribir salarioExtra "extra"
Escribir salarioNeto "neto"

FinProceso

esta es una forma de hacerlo en pseint
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de bryan

algoritmo en c++

Publicado por bryan (3 intervenciones) el 05/04/2014 19:16:59
Proceso algortimo
Escribir "digite el codigo del trabajador"
Leer codigoTrab
Escribir "digite el salario basico que gana en una hora"
Leer salarioBasico
Escribir "digite las horas que a trabajado"
Leer horasTrabajadas
Escribir "digite el numero de horas extras trabajadas"
Leer horasExtrasT
codigo <- codigoTrab
salario <- (salarioBasico*horasTrabajadas)
salarioExtra <- horasExtrasT*(salarioBasico*40)/(100)
Si salarioExtra >= 100000 Entonces
retencionEnfuente <- horasExtrasT*(salarioBasico*10)/(100)
Sino
Si retencionEnfuente < 100000 Entonces
Escribir "no hay retencion en la fuente"
Fin Si
Fin Si
salarioNeto <- (salario+salarioExtra)
Escribir "este es el codigo del trabajador: ", codigo
Escribir "su salario extra:", salarioExtra
Escribir "retencion en la fuente: ", retencionEnfuente
Escribir "ganancias netas del trabajador:", salarioNeto

FinProceso
aqui esta un poco mas completo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar