Algoritmia - algoritmos

   
Vista:

algoritmos

Publicado por leudin russo (1 intervención) el 07/04/2014 15:47:25
me pueden ayudar con este algoritmo
que lea el nombre la cédula y el valor del trabajo de una persona si al finalizar el mes la persona tiene un salario inferior a 600.000 el señor obtendrá un bono de transporte por el 5% del salario un subsidio de alimentación del 5% si el salario de la persona esta entre 600.000 y 1.000.000 la persona tendrá un bono de transporte del 1% y un bono de alimentación del 2% del salario si el salario de la persona es por encima de 1.000.000 la persona recibirá un descuento por impuesto del 7%.

debe mostrar el salario
valor del bono
valor del descuento
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de bryan

algoritmos

Publicado por bryan (3 intervenciones) el 08/04/2014 08:02:33
Proceso algoritmo_ayuda
Escribir "escriba el nombre"
Leer nombre
Escribir "escriba la cedula"
Leer cedula
Escribir "escriba el pago"
Leer pago
Si pago < 600000 Entonces
bonoTransporte <- (pago*5)/100
subsidioAlimentacion <- (pago*5)/100
descuentoImpuesto <- 0
Sino
Si pago >= 600000 y pago <= 1000000 Entonces
bonoTransporte <- (pago*1)/100
subsidioAlimentacion <- (pago*2)/100
descuentoImpuesto <- 0
Sino
Si pago > 1000000 Entonces
descuentoImpuesto <- (pago*7)/100
subsidioAlimentacion <- 0
bonoTransporte <- 0
Fin Si
Fin Si
Fin Si
valorBono <- (bonoTransporte+subsidioAlimentacion)
valorDescuento <- descuentoImpuesto
salarioTotal <- (pago+valorBono)-(descuentoImpuesto)
Escribir "nombre:", nombre
Escribir "su cedula:", cedula
Escribir "valor total del bono:", valorBono
Escribir "el descuento:", valorDescuento
Escribir " su salario total:", salarioTotal

FinProceso
este algortmo esta en Pseint
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar