Android - Problema con Emulador

   
Vista:
Imágen de perfil de Francisco

Problema con Emulador

Publicado por Francisco (12 intervenciones) el 08/09/2016 10:36:35
Tengo una aplicación que funciona perfectamente en una Tablet Samsung Galaxy Tab2 10.1", con una resolución de 1280 x 800 y que sin embargo, cuando la ejecuto en un Emulador de semejantes características deja de funcionar. El primer mensaje de error es este:

Application Installation Failed
Installation failed with message INSTALL_FAILED_INSUFFICIENT_STORAGE.
It is possible that this issue is resolved by uninstalling an existing version of the apk if it is present, and then re-installing.
WARNING: Uninstalling will remove the application data!
Do you want to uninstall the existing application?
OK Cancel
Failure [INSTALL_FAILED_INSOFFICIENT_STORAGE]

Tras pulsar en OK, me aparece este otro mensaje:

DELETE_FAILED_INTERNAL_ERROR
Error while Installing APK

¿Alguien puede resolverme el problema? Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problema con Emulador

Publicado por juanki (221 intervenciones) el 08/09/2016 11:24:33
Hola

En el primer mensaje te dice " INSTALL_FAILED_INSUFFICIENT_STORAGE". Ve a las opciones del emulador y dale más memoria. Es lo que se me ocurre.

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Francisco

Problema con Emulador

Publicado por Francisco (12 intervenciones) el 08/09/2016 12:16:16
Gracias, juanki , por tu consejo, ya lo había hecho subiéndolo de 1 Gb a 500 Gb. Lo he vuelto a hacer y, una vez que termina el Gradle Build Running y el Installing APK, se desconecta y no realiza nada, viéndose en la pantalla del Emulador únicamente “Android” con fondo negro.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Francisco

Problema con Emulador

Publicado por Francisco (240 intervenciones) el 08/09/2016 12:36:40
Puedes desinstalar algunas aplicaciones que tienes instaladas de prueba en emulador.
Y prueba otra vez., a mi me ha pasado algunas veces ,probando códigos la memoria se llena.
Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Problema con Emulador

Publicado por juanki (221 intervenciones) el 08/09/2016 15:42:53
Hola

Si te sale la pantalla del emulador negra y solo con "Android" es que aun no ha cargado, normalmente tarda mucho, pero mucho, en iniciar o es posible que cuando creaste el emulador no lo configuraste correctamente.

Busca por internet "como acelerar emulador android", vas a notar una diferencia enorme a la hora de iniciarse.

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de Francisco

Problema con Emulador

Publicado por Francisco (12 intervenciones) el 08/09/2016 23:02:19
Juanki, parece que Francisco dio con la solución, per también me parece muy buena tu idea de acelerar el emulador. Seguiré tu consejo sobre buscarlo en internet. Gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Francisco

Problema con Emulador

Publicado por Francisco (12 intervenciones) el 08/09/2016 22:58:39
Siento no haber contestado antes. Muchas gracias por la aportación, has solucionado mi problema. Efectivamente, tenía muchas aplicaciones que he ido haciendo de prueba almacenadas. Las he borrado y he conseguido que mi aplicación funcione en el emulador. Nuevamente gracias, tocayo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar