Apache - SEGURIDAD APACHE HTTP1.1 - 400 BAG REQUEST

   
Vista:

SEGURIDAD APACHE HTTP1.1 - 400 BAG REQUEST

Publicado por Hector (2 intervenciones) el 14/04/2014 23:28:18
Buenas tardes,

Hace poco actualicé apache a la versión 2.4 (ultima), tenía anteriormente la versión 2.2 , pero el problema es que intento conectar dispositivos como el Arduino el cual no envia la cabecera HTTP1.1 y retorna el error 400 BAG REQUEST por mal formacion de la petición GET, he intentado habilitando modulos como mod_proxy, mod_headers, para colocar que el servidor apache acepte la peticion de dispositivos como arduino que no envian cabecera pero nada, ninguna configuracion funciona, ademas coloque la intruccion BrowserMatch "Arduino" downgrade-1.0 force-response-1.0 ,
BrowserMatch "Arduino" nokeepalive downgrade-1.0 force-response-1.0 , BrowserMatch "arduino-ethernet" nokeepalive downgrade-1.0 force-response-1.0, con todas las combinaciones que se puedan imaginar pero no he podido lograr que apache acepte las peticiones.

Cualquiera que tenga una idea o que le fuera ocurrido el mismo problema porfavor comenteme .

Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

SEGURIDAD APACHE HTTP1.1

Publicado por xve (236 intervenciones) el 15/04/2014 08:32:40
Hola Hector, el error 400, puede ser por malformación de la url o que el servidor web no entiendo la url que has enviado.

Si utilizas windows, también puede ser por un virus... que tienes que realizar estas acciones...

Primero chequen su equipo con el HijackThis, luego les saldra un monton de letras busquen estas
O4 - HKLM\..\Run: [My Web Search Bar] rundll32 C:\ARCHIV~1\MYWEBS~1\bar\2.bin\MWSBAR.DLL,S

O4 - Global Startup: Reboot.exe

O8 - Extra context menu item: &Search - http://edits.mywebsearch.com/toolbaredits/menusearch.jhtml?p=ZJxdm147YYVE

y recuerden donde estaban q las van a ocupar despues
Ahora:

1.- Apaga el "Restaurar Sistema"

2.- Activa la opción Ver Archivos Ocultos

3.- Reinicia en Modo Seguro y desinstala todo lo relacionado a MyWebSearch

4.- Cierra todos los programas, ejecuta HijackThis y dale "Fix Cheked" a estas entradas:

O4 - HKLM\..\Run: [My Web Search Bar] rundll32 C:\ARCHIV~1\MYWEBS~1\bar\2.bin\MWSBAR.DLL,S

O4 - Global Startup: Reboot.exe

O8 - Extra context menu item: &Search - http://edits.mywebsearch.com/toolbaredits/menusearch.jhtml?p=ZJxdm147YYVE

5.- Sin reiniciar, busca y elimina esta carpeta con todo su contenido:

c:\archivos de programa\MyWebSearch\

6.- Pasa el Ccleaner y siguiendo los pasos de su manual utiliza las opciones Limpiador y Registro.

7.- Descarga el Super Antispyware y realiza un escaneo con el, luego instala SpywareBlaster

8.- Reinicia la máquina y realiza un escaneo con Ewido Online, luego pega otro log de Hijackthis y nos cuentas como te fue.

9.- Deshaz los pasos 1 y 2.


Coméntanos, ok?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

SEGURIDAD APACHE HTTP1.1

Publicado por Hector (2 intervenciones) el 15/04/2014 17:56:52
Buenos días,

Gracias por tu respuesta XVE, pero lo que sucede es que tenemos la siguiente configuración del servidor,

- Apache 2.4
- PHP 5.5
- MYSQL 5.5.35
- UBUNTU SERVER 12.04.2

No creo que sea un virus o algo similar, todo sucedió desde que actualizamos el servidor, antes trabajábamos con la versión APACHE 2.2 y la pasamos a APACHE 2.4, desde ese momento se bloquearon todas las peticiones de los dispositivos (Arduinos, móviles etc) que no envían la cabecera HTTP1.1, que es la que entiende el servidor. Creo que es mas por el protocolo "SERVER_PROTOCOL". Pero la verdad he intentado de todo, pero el servidor no entiende las peticiones y lanza el HTTP1.1 400 BAG REQUEST, en sí entiende peticiones sin la cabecera antes mencionada (HTTP1.1), He intentado configuraciones en apache2.conf, habilitando modulos como modulo mod_header, mod_proxy pero nada.
Quisiera saber si alguien conoce alguna configuración de Apache 2.4 que permita que el servidor entienda las peticiones sin cabecera (HTTP1.1 o HTTP1.0) y que funcione.

Les agradezco.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar