Apache - Symfony2 no funciona, descarga los archivos en vez de ejecutarlos

   
Vista:

Symfony2 no funciona, descarga los archivos en vez de ejecutarlos

Publicado por Eduardo (4 intervenciones) el 24/08/2014 18:43:29
Hola, tengo una maquina virtual con el Vagrant y un apache2 instalado.
Tengo dos sitios web, uno funciona correctamente, en el otro hay un Symony2 recien instalado. El problema es que cuando pongo el dominio me descarga el arhivo en vez de salirme la pagina. Si por ejemplo pongo en el browser www.midominio.dev/config.php, me descarga el archivo config.php en vez de salirme la página con la configuración.
Si en la consola de comando de la maquina virtual hago php app/check.php me sale todo correcto excepto un warning por que no hay acelerador php.

El vhots lo he configurado segun la documentacion de symfony, el archivo para el dominio contiene lo siguiente:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
<VirtualHost *:80>
    ServerName      misitio.dev
    ServerAlias     www.misitio.dev
 
    SetEnv SYMFONY__DATABASE__USER     "..."
    SetEnv SYMFONY__DATABASE__PASSWORD "..."
 
    DocumentRoot    "/var/www/misitio.dev/web"
    DirectoryIndex  app.php
 
    <Directory "/var/www/misitio.dev/web">
        AllowOverride None
        Allow from All
 
        <IfModule mod_rewrite.c>
            Options -MultiViews
            RewriteEngine On
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteRule ^(.*)$ app.php [QSA,L]
        </IfModule>
    </Directory>
 
    CustomLog  /var/log/httpd/misitio.dev-access.log combined
 
    KeepAlive            On
    MaxKeepAliveRequests 200
    KeepAliveTimeout     5
 
    AddOutputFilterByType DEFLATE text/css text/plain text/html application/xhtml+xml text/xml application/xml
 
    <IfModule mod_headers.c>
        Header append Vary User-Agent env=!dont-vary
 
        ExpiresActive On
        ExpiresDefault "now plus 1 week"
        ExpiresByType image/x-icon "now plus 1 month"
        ExpiresByType image/gif    "now plus 1 month"
        ExpiresByType image/png    "now plus 1 month"
        ExpiresByType image/jpeg   "now plus 1 month"
    </IfModule>
</VirtualHost>

Alguien tiene alguna idea? como ya he dicho para el otro host todo funciona, aunque no es un symfony, va sin cms.

Gracias de antemano.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Symfony2 no funciona, descarga los archivos en vez de ejecutarlos

Publicado por xve (236 intervenciones) el 24/08/2014 19:09:59
Hola Eduardo, parece que no tienes instalado el PHP, o que no están incluidas las librerías del PHP en el Apache.

En que sistema operativo lo estas instalando? nos puedes comentar las versiones?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Symfony2 no funciona, descarga los archivos en vez de ejecutarlos

Publicado por Eduardo (4 intervenciones) el 25/08/2014 17:46:14
Hola, como ya he explicado hay tengos dos hosts en ese apache2, en uno hay un typo3 y en otro un symfony2. El typo3 funciona. Y antes de instalar el symfony hize algunas pruebas sin cms. El php iva. Así que el modulo php instalado y en funcionamiento para el otro domino está.
He creado un tercer dominio llamado prueba y le he puesto en el index.php solo una linea con phpinfo(); os dejo la captura de pantalla

captura
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar