Apache - Problemas con permisos en apache con WampServer Version 2.5

   
Vista:

Problemas con permisos en apache con WampServer Version 2.5

Publicado por juanjava (2 intervenciones) el 09/02/2016 19:41:58
Problemas con permisos en apache con WampServer Version 2.5

Trate de hacer lo que dicen los foros pero no me funciono y les explico para ver quien me puede ayudar, muchas gracias

primero en el archivo c:\wamp\bin\apache\apache2.4.9\conf\httpd.conf, modifique la seccion para que quedara como sigue

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
<Directory />
 
#    AllowOverride none
 
#    Require all denied
 
#    AllowOverride all
 
#    Require all allow
 
 
 
     Order deny,allow
 
#	Allow from all
     Deny from all
 
#	usuario01
     Allow from 10.207.7.1
 
#	usuario02
     Allow from 10.207.7.5
 
#	usuario03
     Allow from 10.207.7.25
 
#	y asi sucesivamente
</Directory>
 
queria realizar que en mi red local solo las tres pudieran tener acceso ala pagina web que teclaran, y una de ellas es el servidor en este caso la 10.207.7.1
 
en la seccion siguiente quedo asi para poderla ver en red
<Directory "c:/wamp/www/">
 
    Options Indexes FollowSymLinks
 
 
    AllowOverride all
 
 
 
 
 
 
#   onlineoffline tag - don't remove
 
#    Require local
 
    Require all granted
 
 
</Directory>


y por ultimo en este archivo, descomente la linea de virtual host
# Virtual hosts

Include conf/extra/httpd-vhosts.conf

que no le entendi porque al final incluye estas lineas
#IncludeOptional "c:/wamp/vhosts/*"

Include "c:/wamp/alias/*"


ahora bien en el archivo c:\wamp\bin\apache\apache2.4.9\conf\extra\httpd-vhosts.conf quedo asi

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
# Virtual Hosts
<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot "c:/Apache24/docs/dummy-host.example.com"
    ServerName dummy-host.example.com
    ServerAlias www.dummy-host.example.com
    ErrorLog "logs/dummy-host.example.com-error.log"
    CustomLog "logs/dummy-host.example.com-access.log" common
</VirtualHost>
 
<VirtualHost *:80>
    ServerAdmin webmaster@dummy-host2.example.com
    DocumentRoot "c:/Apache24/docs/dummy-host2.example.com"
    ServerName dummy-host2.example.com
    ErrorLog "logs/dummy-host2.example.com-error.log"
    CustomLog "logs/dummy-host2.example.com-access.log" common
</VirtualHost>
 
#desde aqui yo agregue
<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot "c:/wamp/www"
    ServerName localhost
    ErrorLog "logs/localhost-error.log"
    CustomLog "logs/localhost-access.log" common
</VirtualHost>
 
<VirtualHost *:80>
    ServerAdmin webmaster@midominio.com
    DocumentRoot "c:/wamp/www/sva.com"
    ServerName www.sva.com
    ErrorLog "logs/sva.com-error.log"
    CustomLog "logs/sva.com-access.log" common
</VirtualHost>
 
<VirtualHost *:80>
    ServerAdmin webmaster@midominio.com
    DocumentRoot "c:/wamp/www/pollos.com"
    ServerName www.pollos.com
    ErrorLog "logs/pollos.com-error.log"
    CustomLog "logs/pollos.com-access.log" common
</VirtualHost>

de aqui me fui con los host de windows 8.1 en la carpeta c:\Windows\System32\drivers\etc\hosts y le agregue lo siguiente

1
2
3
127.0.0.1       localhost
127.0.0.1       www.sva.com sva.com
127.0.0.1       www.pollos.com pollos.com

por ultimo en la carpeta de c:\wamp\www\, cree los dos servicios de pagina web quedando asi el subdirectorio
Directorio de c:\wamp\www

1
2
3
4
5
6
7
8
09/02/2016  12:28 p. m.    <DIR>          .
09/02/2016  12:28 p. m.    <DIR>          ..
31/12/2010  09:40 a. m.           202,575 favicon.ico
27/01/2016  07:10 p. m.            23,944 index.php
09/02/2016  12:28 p. m.                 0 pag.txt
28/01/2016  11:21 a. m.    <DIR>          pollos.com
03/02/2016  04:01 p. m.    <DIR>          sva.com
31/12/2010  09:40 a. m.               190 testmysql.php

reinicie servicios y me funciono, le cambiaba ip para darles accesso y negarles acceso y me funciono de maravilla
la situacion fue al dia siguiente encendi y ya no la puedo ver, ni de manera local, que debo de corregir como le hago para verlo en la red con solo algunas ip y como pongo las carpetas de las paginas web, mil gracias por la ayuda
ahora en el navegador me sale

Forbidden

You don't have permission to access / on this server.
Apache/2.4.9 (Win64) PHP/5.5.12 Server at localhost Port 80
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Problemas con permisos en apache con WampServer Version 2.5

Publicado por juan (2 intervenciones) el 11/02/2016 01:25:08
ya soluciones lo de los persmisos por ip con lo que sigue:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Order deny,allow
#	Allow from all
     Deny from all
#	usuario01
     Allow from 10.207.7.1
#	usuario02
     Allow from 10.207.7.5
#	usuario03
     Allow from 10.207.7.25
#	y asi sucesivamente
 
        Require all granted
	Order Allow,Deny
	Allow from 127.0.0.1
#	usuario01
     Allow from 10.207.7.1
#	usuario02
     Allow from 10.207.7.5
#	usuario03
     Allow from 10.207.7.25
#	y asi sucesivamente

pero ahora tampoco me resuelve lo de los vhost no me quedan
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar