C sharp - Activex Internet Explorer C#

   
Vista:

Activex Internet Explorer C#

Publicado por Guillermo Contreras (1 intervención) el 05/06/2009 03:54:39
Estimados,
Junto con saludarlos quisiera pedirles de vuestra ayuda, resulta que desarrolle un activex y funciona salvo algunos problememillas, son 2 activex(.dll), uno se encarga de procesar la info y el otro para verificar que se instalo correctamente (tipo flash player), este lo pruebo a traves de la ip interna http://192.168.3.100/ax/ComprobarInstalacion.html y http://192.168.3.100/ax/PruebaAX.html .
Bajo XP e IE 7 corre muy bien y realiza todo lo que debe hacer, muestra la confirmacion que es un usercontrol con una imagen y realiza los procesos correctamente.
Cuando accedo desde otros OS (Vista y 7) lo instalo manualmente cuando acceso a los Activex por las url anteriores solo me muestra el de la confirmacion y el otro me envia el famoso mensaje error de automatizacion, baje la seguridad del IE (8) y sucede lo mismo, pero, pasa algo muy extraño, copié la carpeta de IIS a la unidad D de los equipos con vista y Win7 y los ejecute directamente haciendo doble click sobre los html y magia todo se ejecuta bien, la pregunta es, que es lo que puede estar pasando?, ojalá me puedan ayudar, se los agradecería mucho.

Asi es como accedo a ellos.

Verificacion.
<object id="obVerifica" name="obVerifica" codebase="MyAX.cab#version=1,0,0,1" classid="clsid:xxxxxx.xxxxxx" widht="100" height="100">

Utilizacion y fragmento del javascript

<object id="obUtil" name="obUtil" codebase="MyAX.cab#version=1,0,0,3" classid="clsid:yyyy.yyyyy.yyyyyy.yyyy" widht="0" height="0">

javascript.
var MyAc=ActiveXObject("MyActivex.Proceso"); //me manda error al acceder desde la red pero no al hacer doble click directamente sobre el html "Error de automatizacion, el servidor no puede crear el objeto."

Saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder