Clipper/FiveWin - Migrar a FWH 32

   
Vista:

Migrar a FWH 32

Publicado por Juan (62 intervenciones) el 08/09/2009 17:39:09
Hola, estoy intentando migrar una aplicación a 32b usando FWH 2.6, xHarbour y xEdit. Consigo compilar en programa pero al ejecutarlo me da un error de PCODE version 5, ya probe con varias versiones de xHarbour y no consigo solucionarlo. Alguien me puede indicar que versiones funcionan correctamente con FWH 2.6?. Realmente funciona xEdit 2.0?, en modo consola si me funciona. Muchas gracias, saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Migrar a FWH 32

Publicado por Gabriel Pascual (914 intervenciones) el 08/09/2009 18:44:37
Tu problema es que estas usando una version de xHarbour nueva, con un versión bastante antigua de FiveWin que sin embargo es una de las mejores, de la version 7.01 en adelante son un dolor de cabeza.

Si estas usando FiveWin 2.6, la version correcta de xHarbour es la 0.99.5 o 0.99.6, la fecha del harobur.exe que te funcionará será anterior al 13/01/2007

Te recomiendo que mires el nuevo XEdit 3:

http://xailer.info/esp/?p=189

Tiene bastantes mas opcines de configuracion con respecto a Harbour y xHarbour, puedes incluso generar entornos que utilicen distitnas versiones de tus herramientas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Migrar a FWH 32

Publicado por Juan (62 intervenciones) el 09/09/2009 11:16:35
En ese Link me descarga la versión que ya tengo, xEdit 2.0. No consigo descargar la versión de xHarbour 0.99.5 o 0.99.6, alguien me la puede pasar?, hay algún Link para descargarla?. Muchas gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Migrar a FWH 32

Publicado por marcelo (161 intervenciones) el 10/09/2009 14:41:06
igualmente para compilar con xEdit tenes que ser mago, yo uso el xEdit como editor, para eso ta bueno, pero para compilar es imposible, ta plagado de errores.
probá con xHarbour, FWH y Verce, con eso funciona muy bien.
Saludos
MArcelo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Migrar a FWH 32

Publicado por Juan (62 intervenciones) el 11/09/2009 11:22:20
Estoy probando tambien con Verce50 y con xHarbour1.0 adaptado por puerto sur y me da el error 'alert.prg' PCODE version:5.

Si uso una version anterior de xHarbour me estos errores:

Error: Unresolved external '_hb_idleSleep' referenced from
Error: Unresolved external '_HB_FUN_HB_DBG_VMSTKLCOUNT' referenced from
Error: Unresolved external '_HB_FUN_HB_DBG_VMPARLLIST' referenced from
Error: Unresolved external '_HB_FUN_HB_DBG_VMVARLGET' referenced from
Error: Unresolved external '_HB_FUN_HB_DBG_VMVARSLEN' referenced from
Error: Unresolved external '_hb_stackST' referenced from

es posible que no tenga la version adecuada de xHarbour?, alguien me puede indicar donde conseguirla?

Saludos
Juan
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Migrar a FWH 32

Publicado por Marcelo (161 intervenciones) el 11/09/2009 17:09:01
no se si es compatible o no, lo que puedo decirte es que tengo:

FWH/FWHX 7.12 December/2007
Borland C++ Compiler 5.5
compilo con el Verce50

y funciona perfecto.

Saludos
Marcelo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Migrar a FWH 32

Publicado por Gabriel Pascual (914 intervenciones) el 11/09/2009 20:07:10
En la distribución de FiveWin (CD o fichero ZIP) debe venir la versión de (x)Harbour que funciona bien con tu versión de FiveWin.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Migrar a FWH 32

Publicado por Luis Ponce (13 intervenciones) el 18/10/2009 23:28:32
Hola Juan

En la pagina de FiveTech, existe una version gratis de FWH la 6.12, alli estan los links necesarios para el xHarbour que esta utiliza, ahi te paso el enlace, bajate lo que necesites

http://www.fivetechsoft.com/spanish/downloads.html

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Migrar a FWH 32

Publicado por antonio (1 intervención) el 12/12/2009 21:57:22
¿cual es el circuito es FWH?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar