Clipper/FiveWin - Error con xEdit

   
Vista:

Error con xEdit

Publicado por Alvaro Wagner (3 intervenciones) el 23/01/2012 18:55:12
Desde hace años, vengo utilizando xEdit para mis aplicaciones, con total satisfacción.

En una de dichas aplicaciones, algo he tenido que cambiar, que al compilar (o ejecutar despues) me salen en la barra de tareas, dos iconos del programa: Uno que corresponde al programa que se está ejecutando correctamente y otro, que si lo pulso, me sale una pantalla toda negra.

¿Alguna manera de solucionar esto?

Un saludo

Alvaro
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Error con xEdit

Publicado por Gabriel Pascual (914 intervenciones) el 06/02/2012 03:33:17
No es un error de XEdit, es un error de las librerias que estas linkando.

En (x)Harbour existen terminales graficas que controlan si la apilcación será para modo consola o para modo gráfico.

Cuando linkas una lib para modo grafico como FiveWin, por ejemplo, tienes que cambiar la libreria para modo consola que te da Harbour (GTGUI.LIB o GTWIN.LIB, dependiendo de la version de (x)Harbour.).

Lo que esta pasando es que cuando arrancas la aplicaicon Windows, tienes como modulo de carga un modulo en modo consola, la pantalla negra que ves es una pantalla de consola (ms-dos) que le sirve de lanzadera a la aplicacion windows.

Solucion: Cambia o quita la libreria de la terminal de texto de tu programa y listo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Error con xEdit

Publicado por Alvaro Wagner (12 intervenciones) el 07/02/2012 17:57:52
Gabriel, muchas gracias. Tienes toda la razon.

Inclui en la aplicación el modulo HaruPdf que tiene un request a la libreria GTWin de xHarbour. La he quitado (desmarcado) y ya funciona correctamente.

De nuevo, muchas gracias.


Alvaro
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Error con xEdit

Publicado por Luis Larco (2 intervenciones) el 01/02/2013 21:14:35
Gracias, pasaba por acá, buscando solución al error mencionado, y su respuesta me ha ayudado mucho. Es simple, supongo, cuando uno sabe dónde están las cosas, pero cuando vas a ciegas, pierdes un tiempo increíble en estos "detalles". Gracias de nuevo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar