Crystal Report - Problema a la hora de mostrar los reportes

   
Vista:

Problema a la hora de mostrar los reportes

Publicado por Joan (1 intervención) el 28/11/2008 15:30:20
Hola a todos,

estoy realizando una aplicación de arquitectura cliente servidor, pero tengo un problema a la hora de mostrar los reportes en Crystal Report con Visual Basic .NET 2003 accediendo a una base de datos en Access.

Resulta que la base de datos a la que accedo puede variar su origen, por ejemplo ponerla en la red o en cualquier otra ruta, pero en cambio no consigo hacer lo mismo a la hora de ejecutar el report y modificarlo por código, es decir, cuando creo un Report le digo un origen de los datos para crearlo, cómo por ejemplo: "C:Archivos de ProgramaMi aplicaciónBd.mdb", y esta ruta se queda fija sin posibilidad de cambiarla por código, ya que cuando ejecuto el informe si la base de datos no está situada en la misma ruta, que he puesto antes, me dice que no existe y me sale una ventana de "Conexión a base de datos" donde está escrito el nombre de la tabla, y me pide el nombre del servidor, la base de datos, el id. de inicio de sesión y la contraseña, además de contener la ruta anterior en el nombre del servidor y la base de datos. Entonces si introduzco una ruta correcta donde si que exista mi base de datos aparece el informe de Crystal Reports correctamente.

He probado de hacer por código (por ejemplo):
dim sRutaNueva as string = "C:RutaNuevaBd.mdb"
informe.SetDatabaseLogon("", "", sRutaNueva, "")

Y no me funciona ya que no lo modifica con ruta que le pongo.

Lo curioso es que en unos pc's me funciona y en otros no. ¿Podría ser por la versión del Compact Framework o algo parecido?

Si alguien me pudiera ayudar se lo agradeceria.....
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder