Crystal Report - Problemas con reporte

   
Vista:

Problemas con reporte

Publicado por arcenett (3 intervenciones) el 05/10/2007 19:46:07
hola a todos , tengo la siguiente consulta:

bueno mejor les cuento todo con detalles.... xD .... tengo 2 tablas en una base de datos sql server una almacena los datos que se imprimiran en un cheque y la otra el detalle del pago , cada tabla tiene un campo folio para poder identificar el detalle correspondiente a cada cheque. a todo esto es para la impresion en masa de cheques.

tengo un crystal reports normal dentro de visual y dentro de ese reporte tengo un subreporte. el problema que tengo es que al momento de mostrar el reporte los datos del primer reporte se ven ok osea si son 3 folios me muestra 1 folio por pagina con sus respectivos datos pero el subinforme que esta incrustado en el reporte principal me muestra el detalle de todos los folios y lo que necesito es que si en la primera pagina esta el folio xx , en el subreporte solo se vea el detalle del folio xx, y asi con las demas paginas.

les agradeceria la ayuda......de todos modos les doy las gracias de antemano... xD
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas con reporte

Publicado por Alberto (15 intervenciones) el 05/10/2007 23:27:06
El problema del subreporte radica en los parámetros que recibe. Para que el subreporte (que hace las veces de detalle), muestre los datos congruentes del reporte principal (que es el maestro), debe recibir los parámetros adecuados del maestro.

Revisa bien qué parámetros le estás enviando los cuales deben ser tomados del reporte principal.

Espero te sirva.

Atte.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con reporte

Publicado por arcenett (3 intervenciones) el 06/10/2007 00:43:27
hola , gracias por tu respuesta... pero no entiendo muy bien lo que dices...

mira lo que hago es que en el reporte principal llamo los datos de la tabla cliente que son en este caso por ejemplo el nombre, folio del documento, fecha actual y fecha del documento,etc.

el subreporte lo lleno con los datos de la tabla detalle, entre esos datos tambien esta el campo folio que utilizo para enganchar la tabla cliente y saber de quien es el detalle que se encuentra guardado pero eso del enganche y filtrado lo hago por visual por ejemplo en una consulta cualquiera, pero lo que yo quiero es que el reporte solito m efiltre esos datos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con reporte

Publicado por Enrique (2 intervenciones) el 29/11/2007 19:40:22
Ok ahi te va, no se si en el crystal que estes usando sea igual, pero lo que tienes que hacer es crear un link al momento de incrustar el subreporte, este link o liga lo que hace es que le dice al subreporte que datos debe mostrar, en este caso el link lo debes crear con el campo del folio, cuando creas el link te dice que campo quieres usar del reporte principal, en este caso el folio y tambien te pregunta contra que campo del subreporte lo quieres comparar, y tambien usaras el campo de folio.

Espero que me haya esplicado bien y que te haya servido para resolver tu problema, bye.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar