Crystal Report - problemas con los tipos de datos Memo

   
Vista:

problemas con los tipos de datos Memo

Publicado por Ricardo Anaya (2 intervenciones) el 10/10/2007 23:44:17
Hola a todos:

En este momento estoy utilizando la version 8.5 de crystal report y estoy tratando de crear unos reportes partiendo de sqlserver, pero el problema es que cuando creo el odbc para conectarme a la base de datos que esta en un servidor y despues desde crystal trato de importar las tablas que voy a utilizar el el reporte, este proceso lo ejecuta la herramienta pero con un error y es que a todos los datos de tipo string, les duplica el tamaño, es decir si en la base de datos tengo un campo que se llama username string(80), en crystal lo veo como username string(160), y por esta razon los campos que al duplicar el tamaño su longitud es mayor a 255 crytal me los cambia a tipo Memo impidiendome trabajar con estos ultimos en formunal que pueda necesitar

Alguien sabe porque me pasa eso

de antemano gracias por la colaboracion que me puedan prestar
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:problemas con los tipos de datos Memo

Publicado por Gerardo (571 intervenciones) el 11/10/2007 01:05:26
Un favor ricardo, establece tu conexión con OLEDB (ADO) y comentame si pasa lo mismo.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:problemas con los tipos de datos Memo

Publicado por Ricardo Anaya (2 intervenciones) el 11/10/2007 01:36:54
no se si esta informacion sirva antes de verificar la conexion con oledb is es que la longitud de los string solo lo hace cuando en la base de datos se declara un campo de tipo nvarchar

saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Reporte se tarda

Publicado por Fortunato Vizuet Lopez (2 intervenciones) el 28/08/2009 20:37:13
Hola.
Mi problema es cuando el usuario quiere desplegar el reporte para imprimir. se tarda hasta media hora para desplegar el reporte en pantalla, y en ocaciones no aparece nada en pantalla, pero sin embargo aparece en la barra de estado (Terminado), como si lla hubiera terminadoel despliegue en pantalla.
cabe mecionar que el reporte es de una hoja a medio llenar.
Como referencia en el visor de suscesos manda manda los siguientes errores:

-MSSQLSERVER No disponible.
- Alert Manager Event Interface No disponible.
- Crystal_inputfileserver No disponible
- Crystal_outputfileserver No disponible
- Crystal_Jobserver No disponible
- Crystal_ReportAPPServer No displible.
- Crystal_Cristalras No disponible.

La version de crystal es Enterprice 10.0 sobre Windows XP Profesional.


Gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Reporte se tarda

Publicado por Fortunato Vizuet Lopez (2 intervenciones) el 28/08/2009 20:37:41
Hola.
Mi problema es cuando el usuario quiere desplegar el reporte para imprimir. se tarda hasta media hora para desplegar el reporte en pantalla, y en ocaciones no aparece nada en pantalla, pero sin embargo aparece en la barra de estado (Terminado), como si lla hubiera terminadoel despliegue en pantalla.
cabe mecionar que el reporte es de una hoja a medio llenar.
Como referencia en el visor de suscesos manda manda los siguientes errores:

-MSSQLSERVER No disponible.
- Alert Manager Event Interface No disponible.
- Crystal_inputfileserver No disponible
- Crystal_outputfileserver No disponible
- Crystal_Jobserver No disponible
- Crystal_ReportAPPServer No displible.
- Crystal_Cristalras No disponible.

La version de crystal es Enterprice 10.0 sobre Windows XP Profesional.


Gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar