Delphi - problemas con adotable

   
Vista:

problemas con adotable

Publicado por vla2 (5 intervenciones) el 14/10/2008 20:06:54
Hola, necesito que alguien me explique lo que estoy haciendo mal, el caso es que tengo una tabla(ado) vinculada con una base de datos en access y todo funciona perfectamente hasta que intento guardar numeros en dos campos que los defino de tipo numero y 4 lugares decimales,

o sea, lleno todos los datos y dejo los numero vacios y guarda bien, escribo algo en esos campos y explota,
el error que me sale es "No se puede encontrar la fila para su actualizacion: algunos valores han cambiado desde la ultima vez que se leyo"

cualquier ayuda o idea sera bien recibida, gracias
saludos
vla2
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:problemas con adotable

Publicado por E.T. (1106 intervenciones) el 14/10/2008 23:37:52
Ya me había topado con ese error, pero no recuerdo la causa, si lo buscas en google, en inglés, te debe de salir
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

mas datos del problema

Publicado por Vla2 (5 intervenciones) el 15/10/2008 15:34:33
hola de nuevo, con dbnavigator me funciona perfectamente, me explico, yo guardo con un boton que puse yo en el form, y me da el error al decir AdoTable.post, pero si le pongo un dbnavigator al form y lo conecto con esa misma tabla guarda perfectamente...
alguna idea?
saludos
vla2
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar