Delphi - Error al migrar

   
Vista:

Error al migrar

Publicado por David (55 intervenciones) el 17/10/2008 12:30:23
Muy buenas a todos.


Mi problema es el siguiente:

Tengo una aplicación en delphi5 y crystal 8 y quiero migrar a delphi 7 y crystal 9.

Cuando compilo me lanza los siguientes errores entre otros:


[Error] UCrpeclasses.pas(1599): Undeclared identifier: 'StatusIsGo'

[Error] UCrpeclasses.pas(1600): Undeclared identifier: 'GetNObjects'

[Error] UCrpeclasses.pas(1607): Undeclared identifier: 'PEObjectInfo'

[Error] UCrpeclasses.pas(1620): Undeclared identifier: 'GetObjectHandle'

y no se lo que puede ocurrir tengo el crystal instalado.....


Gracias por anticipado
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Delphi
- Código fuente de Delphi
- Cursos de Delphi
- Temas de Delphi
- Chat de Delphi
información
Códigos de Delphi
- Creación de una ventana
- OpenGL
- Chat

RE:Error al migrar

Publicado por juancho (193 intervenciones) el 17/10/2008 13:17:39
Oviamente por las librerias, las unidades de la version antigua del cristal ya no son compatibles con la version nueva, debes hacer tu reporte con la version que quieras utilizar y es todo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error al migrar

Publicado por David (55 intervenciones) el 20/10/2008 09:26:35
Gracias por tu rapidez en contestar.

Entonces tengo que cogerme reporte por reporte y volver hacerlos todos......?

Tendre alrededor de 60 reportes si no son mas no quiero imaginarme la gente que tenga que contruir 200 o 300 con sus correspondientes calculos etc....

me parece una locura que los desarrolladores de crystal hayan echo algo asi...

no hay otra forma?

Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error al migrar

Publicado por juancho (193 intervenciones) el 20/10/2008 19:19:02
Es ovio el problema de librerias, o no estas poniendo el path de los componentes, o estas usando componentes para otra version de delphi u otra version del crystal, en teoria los reportes deberian de funcionar instalando los componentes de tu version nueva del crystal (no de la version anterior) que son para delphi 7, no puedes instalar componentes para otra verison de delphi a menos que exista un solo paquete para varias versiones. Y otra cosa es que de la gente de microsoft se espera cualquier cosa, pero estoy de acuerdo contigo, yo tampoco creo que hayan cometido tal desatino, pero como te digo debes de verificar bien el tema de las librerias que te cite antes.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Error al migrar

Publicado por David (55 intervenciones) el 21/10/2008 09:15:03
Gracias voy a dar un vistazo al tema de las path a ver si el problema viene por ahi.

te comento.

Gracias de nuevo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar