Delphi - Problemas con acentos.

   
Vista:

Problemas con acentos.

Publicado por Anna (3 intervenciones) el 21/04/2008 18:29:59
Tengo una base de datos con SQL y tengo problemas con las palabras que llevan acento.
Me salen caracteres raros. Utilizo el Delphi 7.
He mirado por el foro y la solucion del character set, no entiendo quando y donde tengo de poner ISO8859_1. Soy un poco muy novata.
Alguien me puede ayudar por favor.
Muchas gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Delphi
- Código fuente de Delphi
- Cursos de Delphi
- Temas de Delphi
- Chat de Delphi
información
Códigos de Delphi
- Cargar un bitmap
- My Bomber Man
- Trace Route

RE:Problemas con acentos.

Publicado por E.T. (1107 intervenciones) el 21/04/2008 19:41:15
El char set lo pones en tu componente de conexión a la base de datos
P.E. si usas los componentes IBO, para hacer la conexión necesitas un IBODataBase luego en su propiedad CharSet eliges el que le hayas puesto al crear la base de datos.
(Los componentes TTable no tienen CharSe, sino que lo toman del otro componente)

No se que componentes usas para manejar tu base de datos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con acentos.

Publicado por Anna (3 intervenciones) el 22/04/2008 09:37:29
Para manejar la base de datos utilizo dentro de panel de control del windows las Herramientas administrativas.
Gracias.

Anna
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con acentos.

Publicado por Anna (3 intervenciones) el 22/04/2008 09:40:57
Perdon y dentro de las Herremientas utilizo el Origen de datos.(ODBC). Es correcto lo que hago?
Alguien me podria ayudar por favor.
Gracias

Anna
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con acentos.

Publicado por juancho (193 intervenciones) el 22/04/2008 13:12:49
No especificaste que motor usas, en la herramienta en la que creas la base de datos o si la creas con sentencias debes de indicarle que character set va a utilizar la misma eso por lo menos en la mayoria de los motores tienes que hacerlo dependiendo de tu idioma y demas, los character set especifican los caracteres especiales que tienen algunos idiomas cosas como la z brasilera y demas dependen de lo que necesitas yo utiliso Interbase y Firebird y al menos en estos yo utiliso en la mayoria de los casos el WIN1252 que acepta casi todos los caracteres del español como las ñ's, al crear tu base de datos debes especificarla, probablemente la tuya esta usando un default, verifica como creas tu bd y ponle el caracter set que necesitas.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar