Dev - C++ - Programa si dada una ganacia debo pagar algo

   
Vista:
Imágen de perfil de cesar

Programa si dada una ganacia debo pagar algo

Publicado por cesar profesorcesar2003@gmail.com (2 intervenciones) el 13/08/2017 03:50:15
Alli esta la idea pero en cada una de las lineas del ciclo if en pseint dan error Como se hara en C ++ sera mas facil ??


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Algoritmo ganancia
 
	Escribir "escriba un Numero"
 
	definir ganancia como entero
 
	Si ganancia > 60 o ganancia <= 50 Entonces // da un error 
 
		Escribir "debe pagar Bs 5000 o 7000"
 
	Sino
 
		Escribir "DEbe pagar 4000"
 
	Fin Si
 
	Si ganancia > 60 o ganancia <= 80 Entonces // da un error 
 
		Escribir "debe pagar Bs 8000 y 9000 bs"
 
	Fin Si
 
	Si ganancia > 80 y ganancia <= 100 Entonces // da un error 
 
		Escribir "debe pagar Bs 10000 bs"
 
	Fin Si
 
	Si ganancia >  100  Entonces // no da un error 
 
		Escribir "debe pagar Bs 16000 bs"
 
	Fin Si
 
FinAlgoritmo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Programa si dada una ganacia debo pagar algo

Publicado por dario alderaan@ec-red.com (25 intervenciones) el 13/08/2017 06:55:35
Te dejo esto en C++ a ver si te sirve.
Saludos.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
#include <iostream>
 
using namespace std;
 
int main() {
  int ganancia;
 
  cout << "Ingrese su ganancia:";
  cin >> ganancia;
 
  if ((ganancia > 50) && (ganancia <= 60))
    cout << "Debe pagar Bs 5.000 o 7.000" << endl;
  else if ((ganancia > 60) && (ganancia <= 80))
    cout << "Debe pagar Bs 8.000 o 9.000" << endl;
  else if ((ganancia > 80) && (ganancia <= 100))
    cout << "Debe pagar Bs 10.000" << endl;
  else if (ganancia > 100)
    cout <<"debe pagar Bs 16.000" << endl;
  else
    cout << "Debe pagar Bs 4.000" << endl;
 
  return 0;
}
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar
Imágen de perfil de cesar

Programa si dada una ganacia debo pagar algo

Publicado por cesar (2 intervenciones) el 14/08/2017 14:19:55
muchas gracias amigo corrio perfecto
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar