Dreamweaver - Problema al cargar una tipo en mi web

   
Vista:
Imágen de perfil de Miguel

Problema al cargar una tipo en mi web

Publicado por Miguel (12 intervenciones) el 22/09/2014 03:40:22
Hola a todos.

Os estaría agradecidos si alguien me pudiese ayudar con un problema que tengo al cargar una tipografía en una página web que estoy programando. He estado dando vueltas x youtube y por foros y he hecho varias pruebas y no se porque no me funciona de la manera que lo pongo.

El código que he escrito es el siguiente.

@font-face {

font-family: acid;

src:url(fonts/acid.otf)format('opentype');

}

Tengo la sensación de que el problema es la ruta de la fuente, esta se encuentra en mi escritorio en una carpeta que se llama ITT y dentro de esta carpeta están las del proyecto (files, images, fonts, css...).

Si alguien consigue decirme cual puede ser la causa de que no pueda visualizar la tipografía se lo agradecería un montón.

Un saludo a todos!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Dreamweaver
- Cursos de Dreamweaver
- Temas de Dreamweaver
- Chat de Dreamweaver
información
Cursos y Temas de Dreamweaver
- Tutorial Dreamweaver MX Intermedio
- Manual de DreamWeaver
- Manual de CourseBuilder
Imágen de perfil de xve

Problema al cargar una tipo en mi web

Publicado por xve (345 intervenciones) el 22/09/2014 08:35:26
Hola Miguel, la carpeta de las fuentes, tiene que estar dentro de las carpetas de tu pagina web.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Miguel

Problema al cargar una tipo en mi web

Publicado por Miguel (12 intervenciones) el 22/09/2014 12:27:21
De hecho, así es como lo tengo y sigue sin funcionarme.

Ya lo se, es muy triste atascarse en esto que es de lo más tonto pero creo que ya estoy en el punto de aunque tenga el error en frente mía no soy capaz de verlo.

Captura_de_pantalla_2014-09-22_a_las_11.24.07
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Problema al cargar una tipo en mi web

Publicado por xve (345 intervenciones) el 22/09/2014 16:01:32
Prueba a poner la barra al inicio, para que coja de la raiz de tu web... algo así:
1
src:url(/fonts/acid.otf)format('opentype');

ya que si no estas en la raíz de tu web no te funcionaria.

coméntanos, ok?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Miguel

Problema al cargar una tipo en mi web

Publicado por Miguel (12 intervenciones) el 22/09/2014 18:24:32
Empiezo a pensar que mi Dreamweaver está en mi contra.

Captura_de_pantalla_2014-09-22_a_las_16.53.34
Captura_de_pantalla_2014-09-22_a_las_16.53.59
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

Problema al cargar una tipo en mi web

Publicado por xve (345 intervenciones) el 22/09/2014 21:54:37
Hola Miguel, pero si pones que utilice la fuente, si el ordenador no tiene ni Arial, ni Helvetica, ni Sans-serif... creo que cualquier ordenador del mundo tiene alguna de ellas.

Para utilizar fuentes en diferentes navegador, tienes que hacer algo así, ya que cada navegador, utiliza un formato:

1
2
3
4
5
6
7
8
9
10
@font-face {
    font-family: 'open_sansbold';
    src: url('/fonts/OpenSans-Bold-webfont.eot');
    src: url('/fonts/OpenSans-Bold-webfont.eot?#iefix') format('embedded-opentype'),
         url('/fonts/OpenSans-Bold-webfont.woff') format('woff'),
         url('/fonts/OpenSans-Bold-webfont.ttf') format('truetype'),
         url('/fonts/OpenSans-Bold-webfont.svg#open_sansbold') format('svg');
    font-weight: normal;
    font-style: normal;
}

Luego, es tu estilo, utiliza la fuente, pero siempre utiliza primero la que desees...

1
font:normal 11px/14px 'open_sansbold';

Puedes descargar las fuentes que desees con el código correcto en muchas paginas de Internet... por ejemplo: http://www.fontsforweb.com/


Espero que te sirva.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Miguel

Problema al cargar una tipo en mi web

Publicado por Miguel (12 intervenciones) el 23/09/2014 01:25:15
La verdad es que eso lo tenía puesto por que en los textos de mi web he utilizado Helvética (y la escribir la familia sabes que DW te escribe el resto de las fuentes en caso de error), pero para los que son los menús de la web pretendo usar la Acid, que es la que tengo problemas en cargar.

Lo he cambiado y (antes del @font-face) he puesto Helvética dentro de font-family por si hay algún texto que por error vaya sin estilo que no coja alguna de las otras tipos. Pero tristemente el problema para cargar la Acid sigue ahí.

Intentaré ver si puedo solucionarlo de alguna otra manera y por cierto gracias por echarme un cable. ;)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar