Eclipse - Configurando eclipse con tomcat

   
Vista:

Configurando eclipse con tomcat

Publicado por Miguel (2 intervenciones) el 02/11/2013 01:17:58
Hola a todos,

Estoy iniciándome en la programación web con servlets y jsp. Me he descargado Eclipse y Servidor web Apache tomcat 7.0, pero tengo problemas configurandolo.
Tengo eclipse luna y ultima version de tomcat.
En eclipse, agrego nuevo Server Apache Tomcat, le paso la direccion del tomcat en mi equipo, y le pongo la version de Java Jre7. A continuación le cambio la opcion en Server locations: Use server location.

Cuando intento arrancar el servidor desde eclipse, me aparece el siguiente mensaje de error:

Publishing to Tomcat v7.0 Server at localhost...has encountered a problem
Publishing the configuration...

Si miro detalles aparece lo siguiente:

1
2
3
4
5
6
7
8
9
10
11
12
13
Publishing the configuration...
Error copying file to C:/Program Files/Apache Software Foundation/Tomcat 7.0/backup\catalina.policy: C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\catalina.policy (El sistema no puede encontrar la ruta especificada)
C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\catalina.policy (El sistema no puede encontrar la ruta especificada)
Error copying file to C:/Program Files/Apache Software Foundation/Tomcat 7.0/backup\catalina.properties: C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\catalina.properties (El sistema no puede encontrar la ruta especificada)
C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\catalina.properties (El sistema no puede encontrar la ruta especificada)
Error copying file to C:/Program Files/Apache Software Foundation/Tomcat 7.0/backup\context.xml: C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\context.xml (El sistema no puede encontrar la ruta especificada)
C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\context.xml (El sistema no puede encontrar la ruta especificada)
Error copying file to C:/Program Files/Apache Software Foundation/Tomcat 7.0/backup\server.xml: C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\server.xml (El sistema no puede encontrar la ruta especificada)
C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\server.xml (El sistema no puede encontrar la ruta especificada)
Error copying file to C:/Program Files/Apache Software Foundation/Tomcat 7.0/backup\tomcat-users.xml: C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\tomcat-users.xml (El sistema no puede encontrar la ruta especificada)
C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\tomcat-users.xml (El sistema no puede encontrar la ruta especificada)
Error copying file to C:/Program Files/Apache Software Foundation/Tomcat 7.0/backup\web.xml: C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\web.xml (El sistema no puede encontrar la ruta especificada)
C:\Program Files\Apache Software Foundation\Tomcat 7.0\backup\web.xml (El sistema no puede encontrar la ruta especificada)

¿Que puede estar pasando?
El problema está al cambiar a opcion en Server locations: Use server location. Si la dejo en Use workspace metadata puedo arrancarlo sin problemas.

Gracias de antemano y un saludo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Configurando eclipse con tomcat

Publicado por Miguel (2 intervenciones) el 02/11/2013 03:31:23
Solucionado: Hay que instalar el servidor web manualmente a traves del zip de la pagina oficial, y no a traves del instalador windows.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar