Excel - pegado columnas intercaladas

   
Vista:

pegado columnas intercaladas

Publicado por miguel (1 intervención) el 29/07/2008 00:29:16
Que tal tengo un pequeño problema, digamos que tengo por ejemplo lo sig:
a b c d
| | |
| | |
| | |
| | |
| | |
| | |

Y en cada columna tengo informacion, lo que quiero es lo siguiente: Pasar esa informacion pero de forma intercalada a una forma como la siguiente

a b c d

X
Y
X
Y
.
.
.


Y mi problema es el siguiente quiero que toda la informacion que tengo se pegue pero solo en las filas que tienen la X. Si alguien me podria ayudar se los agradeceria mucho ya que el archivo que estoy trabajando es de casi 5000 filas
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:pegado columnas intercaladas

Publicado por Luis Fernando (805 intervenciones) el 29/07/2008 02:56:38
Suponiendo que tus datos están originalmente en la hoja1 columnas A B C y que en la hoja2 solo tienes las "X" y "Y" por la columna "A"
Entonces por ejemplo en B1 puedes tener

=SI($A1="X";INDICE(Hoja1!$A$1:$C$117;CONTAR.SI($A$1:$A1;$A1);1);"-")

en C1

=SI($A1="X";INDICE(Hoja1!$A$1:$C$117;CONTAR.SI($A$1:$A1;$A1);2);"-")

en D1

=SI($A1="X";INDICE(Hoja1!$A$1:$C$117;CONTAR.SI($A$1:$A1;$A1);3);"-")

con esto siempre que en A1 y de ahi para abajo tengas una "X" las anteriores formulaciones te traerán los datos de la hoja 1 columnas A B C

espero sea esto lo que requieres.

Cordial saludo desde Pereira Colombia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar