Excel - Fórmulas con muchas condicionales

   
Vista:

Fórmulas con muchas condicionales

Publicado por Sara (4 intervenciones) el 18/08/2008 22:34:32
Saludos, necesito de su ayuda para resolver lo siguiente:
Tengo las siguientes condiciones y su respectiva fórmula:

Condición fórmula
0<x<90 90-x
90<x<180 x-90
180<x<270 270-x
270<x<360 x-270

Tengo los datos en la columna A y deseo obtener los resultados en la columna B (calculados con las formulas de arriba ). Por ejemplo:

A B
2 88
100 10
300 30
195 75
.
.
.
.
He intetado darle solución a mi problema usando las condicionales múltiples (si vale el término), SI(A1<90,90-A1,SI(90<A1<180,A1-90,SI(180<A1<270,270-A1,A1-270))). pero no resulta.
Gracias por su respuesta..
Sara.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Fórmulas con muchas condicionales

Publicado por Santiago (193 intervenciones) el 18/08/2008 23:54:50
La formula es =SI(Y(A2>0,A2<=90),90-A2,SI(Y(A2>90,A2<=180),A2-90,SI(Y(A2>180,A2<=270),270-A2,A2-270)))

Un saludo
SCM
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Fórmulas con muchas condicionales

Publicado por jcs (494 intervenciones) el 19/08/2008 00:10:58
Muy buenas,

He probado la siguiente fórmula y funciona:

=SI(A1<90;90-A1;SI(A1<180;A1-90;SI(A1<270;270-A1;A1-270)))

Algunas matizaciones:

- Tal como lo describes no se sabe lo que pasa en caso de igualdad. Con la fórmula que te he puesto cumpliría con tramo superior.

- Lo que pretendes con 90<A1<180 no es la forma correcta de ponerlo, en excel habría que poner Y(A1>90; A1<180), pero tampoco es necesario indicarlo así, ya que si A1 fuera menor que 90, ya se habría cumplido la condición anterior y no evaluaría esta.

- Si la fórmula no te funciona, cambia los ";" por ","

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Fórmulas con muchas condicionales

Publicado por Sara (4 intervenciones) el 19/08/2008 01:58:46
Mil gracias por la solución Santiago y jcs.
Un cordial saludo.
Sara.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar