Excel - Copiar valor ultima celda

   
Vista:

Copiar valor ultima celda

Publicado por Carlos (1 intervención) el 30/10/2008 23:19:37
Hola a todos:

Quisiera copiar en una celda, la última celda con valor distinto de cero, de un rango correspondiente a una columna, que recoge la suma de varias celdas (tiene fórmula).Este rango, por ejemplo A1:A70, tiene de A1 a A50, tienen cifras(suman celdas), y de A51 a A70, no.

Por mediación de macro logro ir a la celda A70 ( me recoge esta por tener valor 0). ¿Como podría llegar a la última celda con cifra (A50), por medio de código.Supongo que habría que poner un condicionente parecido a <>0, pero no sé como hacerlo.

Muchas gracias anticipadas a todos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Copiar valor ultima celda

Publicado por Luis Fernando (805 intervenciones) el 02/11/2008 01:36:23
Que tal si usas algo como la función siguiente:

=BUSCARV(9E+307;A1:A70;1;1)

Con ella se trae el último valor del rango dado A1:A70, segun tu ejemplo el de la celda A50
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar