Excel - Buscar

   
Vista:

Buscar

Publicado por Mayra (8 intervenciones) el 17/04/2009 19:52:02
Hola, buen dia.

Tengo un problema, espero me puedan auxiliar..Se los comento..
En una hoja tengo una base de datos con un campo llamado serial
y en otra hoja tengo otra base de datos donde tengo el mismo campo serial y una fecha,
ahi hay seriales que estan duplicados pero con diferente fecha..

En una tercera hoja, quisiera buscar los seriales de la hoja1 en la hoja2 y que me traiga las fechas,
Lo podria hacer con un vlookup o vbuscar, pero solo me trae la fecha del primer dato que encontro, y lo que quiero es que me traiga todas las fechas.

Ejemplo:

Hoja 1
Serial
150
200
300

Hoja2
Serial Fecha
150 15/01/09
150 12/02/09
150 03/03/09
200 12/12/08

Hoja3
Serial Fechas
150 15/01/09 12/02/09 03/03/09
200 12/12/08
300 #N/A

Espero haberme explicado..
Gracias de Antemano

Mayra
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Buscar

Publicado por Luis Fernando (805 intervenciones) el 19/04/2009 04:34:11
Por ahi vi una respuesta a un caso como el tuyo que diereon en otro foro:

=SI(ESNUMERO(K.ESIMO.MENOR(SI(Sheet1!$A$1:$A$7=Sheet1!$A10;Sheet1!$B$1:$B$7);COLUMNA(INDIRECTO("1:"&FILAS(Sheet1!$A$1:$A$7)))));K.ESIMO.MENOR(SI(Sheet1!$A$1:$A$7=Sheet1!$A10;Sheet1!$B$1:$B$7);COLUMNA(INDIRECTO("1:"&FILAS(Sheet1!$A$1:$A$7))));"")

Ah pero es con matriciales luego en ludar de dar ENTER solo a esta formulación debes de darle CTrl Shift ENTER

Cordial saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar