Excel - Varias condiciones en una

   
Vista:

Varias condiciones en una

Publicado por Diego (1 intervención) el 01/05/2009 19:04:33
Hola:

Quisiera saber como puedo hacer varias condiciones en una.
Me refiero a que tengo una columna de valores
0.0005
0.0010
0.0200
0.154
0.5
1

y otra con numeros aletorios. Lo que pretendo es que si el primer numero aleatorio esta entre 0 y mi primer numero, en este caso 0.0005 me de un 0 si esta entre 0.005 y 0.0010 me de 1 si esta entre 0.010 y 0.0200 me de 3 y asi con todos

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de JuanC

RE:Varias condiciones en una

Publicado por JuanC (1053 intervenciones) el 02/05/2009 12:49:05
deberías usar las funciones lógicas SI e Y junto con los operadores > y <

Ej: =SI(Y(A1>0;A1<1); 1; 0)

Saludos desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Varias condiciones en una

Publicado por jcs (494 intervenciones) el 05/05/2009 10:34:26
Muy buenas,

si te he entendido, considerando que los valores que has puesto están en las celdas A1 a A6, y que el valor aleatorio estuviera en D1, te podría valer la siguiente fórmula:

=SI(ESERROR(COINCIDIR(D1;$A$1:$A$6;1));0;COINCIDIR(D1;$A$1:$A$6;1))

Para simplificar un poco la fórmula, podrías poner en A1 un cero y tus valores de A2 a A7, así la fórmula quedaría así:

=COINCIDIR(D1;$A$1:$A$7;1)-1

Espero que te sirva.

Un saludo. Juanjo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar