Excel - contar palabras

   
Vista:

contar palabras

Publicado por lourdes (16 intervenciones) el 18/05/2009 14:53:23
¿Alguien sabe como se pueden contar todas las palabras de un libro de Excel?. Lo necesito para valorar el coste de una traducción qeu se paga por palabra traducida.

Muchas gracias y saludos.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de JuanC

RE:contar palabras

Publicado por JuanC (1052 intervenciones) el 18/05/2009 16:37:19
creo que la solución es programar una macro
no sé cómo están los datos en la hoja (una palabra x celda o más)
para poder usar funciones...

Saludos desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:contar palabras

Publicado por lourdes (16 intervenciones) el 19/05/2009 13:49:17
Muchas gracias por la respuesta
Como con las macros me defiendo más mal qeu bien, seguiré con la chapuza de pasarlo a un word. De todas formas gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:contar palabras

Publicado por Susana (2 intervenciones) el 28/06/2009 03:34:02
Yo andaba en lo mismo y encontré esta fórmula en la web, quizás la puedas aplicar:

=SUMA(SI(LARGO(ESPACIOS(B2))=0;0;LARGO(ESPACIOS(B2))-LARGO(SUSTITUIR(B2;" ";""))+1))

También puedes aplicar la siguiente macro:

Function contarpalabras(celda As Range)
'si ponemos un espacio antes de los signos de
'puntuación, mejor los eliminamos del cómputo
datos = Replace(celda, ".", "")
datos = Replace(datos, ",", "")
datos = Replace(datos, ";", "")
datos = Replace(datos, ":", "")
'reemplazamos los posibles dobles espacios
datos = Replace(datos, " ", " ")
'eliminamos los espacios inicial y final
datos = Trim(datos)
'Descomponemos la cadena, en subcadenas,
'para lo cual indicamos el delimitador " ", aunque
'por defecto, podríamos haberlo omitido,
'pues es ese mismo (espacio)
palabras = Split(datos, " ")
'Buscamos el máximo de palabras que se han
'formado, y le sumamos 1, porque el array
'comienza a contar desde cero
numero_de_palabras = UBound(palabras) + 1
'asignamos ese máximo a la función
contarpalabras = numero_de_palabras
End Function
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:contar palabras

Publicado por Susana (2 intervenciones) el 28/06/2009 03:36:22
Yo andaba en lo mismo y encontré esta fórmula en la web, quizás la puedas aplicar:

=SUMA(SI(LARGO(ESPACIOS(B2))=0;0;LARGO(ESPACIOS(B2))-LARGO(SUSTITUIR(B2;" ";""))+1))

También puedes aplicar la siguiente macro:

Function contarpalabras(celda As Range)
'si ponemos un espacio antes de los signos de
'puntuación, mejor los eliminamos del cómputo
datos = Replace(celda, ".", "")
datos = Replace(datos, ",", "")
datos = Replace(datos, ";", "")
datos = Replace(datos, ":", "")
'reemplazamos los posibles dobles espacios
datos = Replace(datos, " ", " ")
'eliminamos los espacios inicial y final
datos = Trim(datos)
'Descomponemos la cadena, en subcadenas,
'para lo cual indicamos el delimitador " ", aunque
'por defecto, podríamos haberlo omitido,
'pues es ese mismo (espacio)
palabras = Split(datos, " ")
'Buscamos el máximo de palabras que se han
'formado, y le sumamos 1, porque el array
'comienza a contar desde cero
numero_de_palabras = UBound(palabras) + 1
'asignamos ese máximo a la función
contarpalabras = numero_de_palabras
End Function
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar