Excel - Sumar con dos condiciones

   
Vista:

Sumar con dos condiciones

Publicado por melilla (3 intervenciones) el 05/12/2009 15:02:25
Estoy bloqueado.
1.- NO PUEDO instalar en la máquina SUMAPRODUCTO
2.- Necesito sumar en la Hoja2 en las celdas que corresponden con la fecha, todos los códigos iguales existentes en la columna A de la Hoja1 ,

Dicho de otro modo, si pudiese usar SUMAPRODUCTO (en la misma Hoja1), la fórmula que realiza bien el trabajo sería la siguiente para obtener el total del código "a1" y fecha "ene-09":

=SUMAPRODUCTO((A2:A101="a1")*((B2:B101=FECHANUMERO("01/01/2009"))*(C2:C101)))

¿Alguién me puede dar una solución alternativa? ....

¡GRACIAS ANTICIPADAS!

=========================================
Hoja1

A B C D

codigo fecha coste concepto
a1 ene-09 22,1 patatin
b3 feb-09 39,04 patatan
a1 mar-09 42,88 prirulin
c2 ene-09 1300 pirulan
a2 feb-09 983 patatan
b2 mar-09 610 prirulin
c3 feb-09 7272 pirulan
a3 mar-09 2388 patatan
b1 ene-09 80 prirulin
b2 ene-09 100 pirulan
c2 feb-09 74 patatan
a2 mar-09 222 prirulin
b3 ene-09 4844 pirulan
b1 feb-09 22,1 patatin
b2 mar-09 39,04 patatan
c2 feb-09 42,88 prirulin
a2 mar-09 1300 pirulan
b3 ene-09 50000 patatan
C1 ene-09 732 silose
C2 feb-09 9811 nomemeto
C2 mar-09 80000 eneste
C2 feb-09 287 fregadocon
C1 mar-09 21 lampazo
C3 mar-09 11 nihallacas

========================================

Hoja 2

A B C D
1 codigo fecha
2 ene-09 feb-09 mar-09

3 a1 Fórmula Fórmula Fórmula
4 a2 Fórmula Fórmula Fórmula
5 a3 Fórmula Fórmula Fórmula
6 b1 Fórmula Fórmula Fórmula
7 b2 Fórmula Fórmula Fórmula
8 b3 Fórmula Fórmula Fórmula
9 c1 Fórmula Fórmula Fórmula
10 c2 Fórmula Fórmula Fórmula
11 c3 Fórmula Fórmula Fórmula
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Sumar con dos condiciones

Publicado por raul (10 intervenciones) el 05/12/2009 20:08:51
usando una columna auxiliar la cual podra estar oculta, en esa columna ceaas un codigo unico para cada registro usando la funcion conatenar.. &.. para codigo y fecha
=A2&B2.. con esto se cea un codigo unico..

ahora en la otra hoja pones los dos criterios.. codigo y fecha, usando la funcion sumar.si podras sacar la suma..

suponiendo que el codigo unico quedo en A1 de la base de datos y en la otra hoja pusiste los criterios en A Y B

=sumar.si(A2:A101,A1&B1,C2:C101)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar