Excel - Extraer datos de columna

   
Vista:

Extraer datos de columna

Publicado por Raziel (243 intervenciones) el 18/01/2010 19:09:15
Hola buenos dias!
Tengo la siguiente problematica, con macros talvez lo pueda solucionar rapidamente pero deseo hacerlo mediante formula, me explico...

A1 = 3
A2 = N/D
A3 = 5
A4 = 9
A5 = N/D
A6 = 6
A7 = 8
A7 = 12
A9 = N/D

Tengo otro rango de B1:B9 en el que pretendo extraer los datos contenidos del rango A1:A9 de forma consecutiva de modo que quede algo asi...

B1 = 3
B2 = 5
B3 = 9
B4 = 6
B5 = 8
B6 = 12
B7 =
B8 =
B9 =

N/D quiere decir que la celda no contiene dato, tambien cabe señalar que los numeros nunca se repiten.
Una mano porfa!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Extraer datos de columna

Publicado por jcs (494 intervenciones) el 19/01/2010 22:26:38
Muy buenas,

mira a ver si te sirve esto:

=SI(ESERROR(K.ESIMO.MENOR(A$1:A$9;FILA(A1)));"";K.ESIMO.MENOR(A$1:A$9;FILA(A1)))

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Extraer datos de columna

Publicado por Raziel (243 intervenciones) el 20/01/2010 01:23:28
Hola Juanjo, muchas gracias por la respuesta, es justo lo que necesitaba.
Saludos!!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar