Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Iniciar sesiónIniciar sesiónCrear cuentaCrear cuenta

Excel - CONDICION HORARIAS

  Imprimir  
Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:

CONDICION HORARIAS

Autor:JULEN (28 intervenciones)
Fecha:05/02/2010 11:43:19
Muy buenas,tengo un problema que no acierto a resolver:
tengo 2 turnos de trabajo, 1 y 2.
En el turno 1 puedo entrar antes de las 13.30 y acabar despues de las 15.30 dandome como resultado un valor 1, para lo cual tengo esta formula:

SI($A1="";"";SI($B1="";"";SI(Y($A1<NSHORA(13;30;0);$B1>NSHORA(15;30;0));1;"")))

El problema viene cuando entro en el turno 2 que empiezo antes de las 13.30, pero puedo acabar antes o despues de las 15.30 para lo cual necesitaria que me devolviese el mismo valor. He añadido una columna mas añadiendo el turno correpondiente, para poder decirle,

SI($D1=1........... Y .....SI($D1=2..........PERO NO ACABO DE DAR CON LA SOLUCION ADECUADA, NO SE IGUAL LA TENGO DELANTE DE LAS NARICES PERO A VECES LO MAS OBVIO ES LO QUE NO VES.
A ver si me podeis echar una mano.
Gracias.
Responder
información
Otras secciones de LWP con contenido similar...
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:CONDICION HORARIAS

Autor:Raziel (240 intervenciones)
Fecha:06/02/2010 20:33:33
Hola Julen, estoy intentando comprender tu problema pero no me queda muy claro, veamos...

Turno1 = 1 Cuando Entrada <13:30 y Salida >15:30
Turno2 = ? Cuando Entrada <13:30 y Salida <15:30 o Salida >15:30

Si mi planteamiento es correcto, entonces, tenemos algunas ambiguedades...

1.- En Turno1, si Entrada >13:30 y/o Salida <15:30 que sucede?
2.- En Turno2, si Entrada >13:30 que sucede?
3.- En Turno2, si se cumplen las condiciones que sucede?

Por ultimo, tal y como expones el problema, si no agregas una columna que indique de que turno se trata es probable que, en algunas ocaciones, cuando esperes que el resultado sea el valor que le asignes a Turno2, obtengas el valor de Turno1 esto porque las condiciones que indicas son practicamente las mismas...

Ojalas y nos regales mas datos para poder ayudarte.
Saludos!
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:CONDICION HORARIAS

Autor:JULEN (28 intervenciones)
Fecha:08/02/2010 17:55:25
Hola Raziel,te explico:
tengo una columna donde tengo por titulo , TURNO, y en cada celda correspondiente introduzco manualmente 1 si es de mañana, o 2 si es de tarde.
En el turno de mañana, si empiezo antes de las 13,30 y acabo despues de las 15,30 me da como resultado 1 , si no se cumple esta condicion me da "" , que como observaras es la formula que he colgado.

En el turno 2, empiezo antes de las 13,30 (que es igual que el turno 1) pero puedo acabar antes o despues de las 15,30 , es decir no tengo hora fija y la formula me tiene que dar como resultado 1 si se cumple la condiccion o "" si no se cumple.

Solamente introduzco 1 o 2 dependiendo del turno

Para lo cual he hecho esta formula real para no liarme:

=SI($D$3="";"";SI($D$3=1;SI($I3="";"";SI($J3="";"";SI(Y($I3<NSHORA(13;30;0);$J3>NSHORA(15;30;0));1;"")))))

Bien , con esta formula he conseguido, que si se cumple la condiccion, me devuelva 1 o "" hasta aqui correcto, ahora necesito que que se cumpla la segunda condiccion y he aqui el problema, no se como plantearlo, porque es que no encuentro la manera.
Espero que te halla sacado de dudas, de no ser asi te puedo mandar el archivo o lo que necesites.
Gracias por vuestra alluda.
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:CONDICION HORARIAS

Autor:Raziel (240 intervenciones)
Fecha:08/02/2010 18:41:05
A ver si le entendi.

De A2 a C2 como Turno, Hora Entrada y Hora Salida respectivamente...

=SI(Y(A2=1,HORA(B2)<=13,MINUTO(B2)<=30,HORA(C2)>=15,MINUTO(C2)>=30),1,SI(Y(A2=2, HORA(B2)<=13,MINUTO(B2)<=30,NO(ESBLANCO(C2))),1,""))

No olvides cambiar las comas por punto y coma.

Te comento que no soy experto ni nada por el estilo, es probable que se pueda hacer mejor...

Cuentame como te fue.
Saludos!
Comentar
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:

RE:CONDICION HORARIAS

Autor:JULEN (28 intervenciones)
Fecha:09/02/2010 15:18:53
Gracias Raziel,me voya poner con ello mañana , te comentare como va, de todas manerasy visto un poco por encima creo entender de como lo enfocas, en los proximos dias te mandare una nota de como me a ido.
Muchas gracias por todo.
Comentar