Excel - Sumar si

   
Vista:

Sumar si

Publicado por LILO (3 intervenciones) el 16/02/2010 17:50:09
Tengo una duda quisiera saber como poner una condición si en la columna A tengo codigo, B Producto, C Total, lo que quiero es que si hay 2 o mas codigos iguales me saque un total por codigo.

A B C
CODIGO PROD TOTAL
1236 CANDY 100
1239 CHIC 120
1236 CANDY 23
1236 CANDY 100
1236 CANDY 50
1289 MOL 40
1239 CHIC 100

Por ejemplo aqui saldrian 273 para el codigo 1236 y para el codigo 1239 tendria que salir 240.

Muchas gracias por la ayuda.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Sumar si

Publicado por lucho (60 intervenciones) el 16/02/2010 19:35:35
Saludos Lilo:
Ojalá te sirva la siguiente función:
=SUMAR.SI(A2:A8,A10,C2:C8)
Por ejemplo en a10 anotas 1236, a11 anotas 1239 y por último en a12 anotas 1289
Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Sumar si

Publicado por lilo (3 intervenciones) el 16/02/2010 20:39:20
Lo que pretendo hacer es que se haga de manera automatica sin necesidad de estar cambiando yo manualmente po codigo. Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Sumar si

Publicado por Raziel (243 intervenciones) el 16/02/2010 23:26:49
Hola LILO, sin desestimar tu necesidad, te aporto una solucion SIN CODIGO...

Agrego una columna a tu listado cod-prod-total quedan en B,C y D respectivamente, ahora, pegas en A2 =SI(CONTAR.SI(B2:$B$8,B2)=2,CONTAR.SI(B2:$B$8,B2)*FILA(),"") y arrastras hasta A8.

En A12 y A13 =K.ESIMO.MENOR($A$2:$A$8,FILA()-11)
En B12 =BUSCARV(A12,$A$2:$B$8,2,FALSO) y lo arrastras a B13
En C12 =SUMAR.SI($B$2:$B$8,B12,$D$2:$D$8) y lo arrastras a C13

Creo que un resultado parecido lo podrias obtener mediante subtotales, y talvez tambien por tabla dinamica y filtros...

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Sumar si

Publicado por LILO (3 intervenciones) el 17/02/2010 00:55:02
Te agradezco muchisimo Raziel esto funciona perfecto, ya solo me falta entender algunas sentencias, esta perfecto. Muchas gracias!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar