Excel - Contar usando criterios de busqueda

   
Vista:

Contar usando criterios de busqueda

Publicado por Percy (17 intervenciones) el 19/05/2010 05:23:13
Amigos, nuevamente recurro a ustedes por una consulta.

Veran, tengo un listado de 10 registros de paises, el cual tiene en 3 columnas (B;C;D) datos de goles por cada colmna.

A B C D
1 PERU 1 8 5
2 ECUADOR 9
3 ARGENTICA 5 9
4 CHILE 6 6
5 ARGENTICA 2
6 CHILE 8
7 PERU 6 9
8 CHILE 6 8
9 ECUADOR 3 5
10 PERU 5 6

la idea es lorar el siguiente cuadro:

PERU ECUADOR ARGENTICA CHILE
B 2 1 2 1
C 2 1 1 3
D 3 1 0 1

com veran lo unico que se deve de hacer es contar cuantas celdas estan llenas por cada columna y por cada pais:

Ejemplo´: pais PERU y columna B tiene solo 2 celdas llenas.

Por favor, alguien me ayuda con este tema.

Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Contar usando criterios de busqueda

Publicado por jcs (494 intervenciones) el 19/05/2010 20:22:47
Muy buenas,
aunque es un pelín complicado de entender, sobre todo porque no se ve puede apreciar que columnas son las que tienen datos, creo que al final me he hecho a la idea de lo que quieres.
Así, la solución sería poner PERU .... CHILE en las celdas E1 ... H1.
En la celda E2:
=SUMAPRODUCTO(($A$1:$A$10=E$1)*($B$1:$B$10<>""))
E3
=SUMAPRODUCTO(($A$1:$A$10=E$1)*($C$1:$C$10<>""))
E4
=SUMAPRODUCTO(($A$1:$A$10=E$1)*($D$1:$D$10<>""))
Luego copia y pega hasta H4

Espero que te sirva.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Contar usando criterios de busqueda

Publicado por roberto (1 intervención) el 07/02/2013 18:59:58
Excelente, no se si te contesto el que hizo la pregunta pero a mi me ha servido grandemente, saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar