Excel - UNA COSA QUE PARECÍA TAN SENCILLA Y...

   
Vista:

UNA COSA QUE PARECÍA TAN SENCILLA Y...

Publicado por JOSHEP (10 intervenciones) el 02/09/2010 19:49:38
Simplemente trato de que en una casilla cualquiera, aparezca un número, respecto a otro número que existe en la casilla A1 y que puedo modificar:

=SI(A1=1;"8";SI(A1=2;"7";SI(A1=3;"6";SI(A1=4;"5";SI(A1=5;"4";SI(A1=6;"3";SI(A1=7;"2";SI(A1=8;"1";SI(A1=9;"12";SI(A1=10;"11";SI(A1=11;"10";SI(A1=12;"9"))))))))))))

PERO ME APARECE UN FALLO A PARTIR DE A1=9
;SI(A1=9

NO ENTIENDO PORQUE. HE INTENTADO DE TODO Y NADA DE NADA. QUIZÁS LA FÓRMULA QUE HE ELEGIDO NO ES LA CORRECTA PARA ESTO ?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:UNA COSA QUE PARECÍA TAN SENCILLA Y...

Publicado por Raziel (243 intervenciones) el 02/09/2010 20:10:54
He revisado tu formula y no encuentro el error, lo que si observo es que se podria mejorar un pelin, aca mi propuesta:

=BUSCAR(A1,{1;2;3;4;5;6;7;8;9;10;11;12},{8;7;6;5;4;3;2;1;12;11;10;9})

Si te marca error (por configuracion regional) prueba sustituir las comas por punto y coma y los punto y comas por diagonales o por comas, aca tienes que hacer las pruebas por que entre version y configuracion esta formula se comporta "raro", o puede que no la termine de enteder, jejeje, resuelto!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

NADA, NI CON ESAS FUNCIONA. INCREIBLE

Publicado por JOSHEP (10 intervenciones) el 02/09/2010 20:26:20
Lo intentado con tu fórmula y las opciones, y me dice que ERROR.

FIJATE, HASTA AQUÍ BIEN.
=SI(A1=1;"8";SI(A1=2;"7";SI(A1=3;"6";SI(A1=4;"5";SI(A1=5;"4";SI(A1=6;"3";SI(A1=7;"2";SI(A1=8;"1"))))))))

Y DE AHÍ PARA ADELANTE, YA NO FUNCIONA.
=SI(A1=1;"8";SI(A1=2;"7";SI(A1=3;"6";SI(A1=4;"5";SI(A1=5;"4";SI(A1=6;"3";SI(A1=7;"2";SI(A1=8;"1";SI(A1=9;"12";SI(A1=10;"11";SI(A1=11;"10";SI(A1=12;"9"))))))))))))
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:NADA, NI CON ESAS FUNCIONA. INCREIBLE

Publicado por Raziel (243 intervenciones) el 02/09/2010 20:52:45
intenta asi...

=BUSCAR(A1;{1,2,3,4,5,6,7,8,9,10,11,12};{8,7,6,5,4,3,2,1,12,11,10,9})

La formula que te propongo es mucho mas eficiente que la que intentas usar, simplemente editarla es un lio, si te sigue mostrando error entonces busca en la ayuda de excel y fijate que caracter utiliza para separar los digitos.
Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:NADA, NI CON ESAS FUNCIONA. INCREIBLE

Publicado por Enrique54 (90 intervenciones) el 03/09/2010 00:01:01
Para la pregunta original porque no le funciona el =Si(tatataaaaa)
El Excel tiene el limite de 7 si internos
documentado en la ayuda del mismo Excel
segun que porque se asemeja al humano que somos que no manejamos mas de 7 cosas a la vez
de ahi que las propuestas alternativcas sean aplicables en tanto operen como se necesita
Saludos
Smogpolis Mexico
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:NADA, NI CON ESAS FUNCIONA. INCREIBLE

Publicado por Antoni Masana (16 intervenciones) el 03/09/2010 10:44:35
El mensaje de error es bastanta explicito por si mismo:

No se puede utilizar la fórmula especificada porque usa más niveles de anidamiento de los permitidos en el formato de archivo actual.

La Solucion:

Por ejemplo en la columna E de pones los numeros a buscar (Fila del 1 al 12) y la columna F los numeros a buscar (Fila del 1 al 12) y donde quieras la formula:

=BUSCAR(A1;E1:E12;F1:F12)

Saludos desde Barcelona, España.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:NADA, NI CON ESAS FUNCIONA. INCREIBLE

Publicado por Luis Fernando Giraldo (805 intervenciones) el 04/09/2010 02:06:14
La limitante de funciones SI anidados estaba hasta la version 2003 pero ya en la 2007 no esta este limitante
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:SOLUCIONADO, puntos y comas por un tubo

Publicado por JOSHEP (10 intervenciones) el 03/09/2010 14:55:20
GRACIAS a todos por la ayuda.

=BUSCAR(A1;{1;2;3;4;5;6;7;8;9;10;11;12};{8;7;6;5;4;3;2;1;12;11;10;9})

al parecer los puntos y comas son los favoritos en mi PC, y esto parece funcionar todo con puntos y comas.
CHAO Y HASTA LA PRÓXIMA.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:UNA COSA QUE PARECÍA TAN SENCILLA Y...

Publicado por lucho (60 intervenciones) el 06/09/2010 23:44:25
Saludos Joshep:
Aplica la siguiente función:
=SI(O(A1=1,A1=2,A1=3,A1=4,A1=5,A1=6,AI=7,A1=8,A1=9,A1=10,A1=11,A1=12),A1)
Suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar