Excel - Validar si hay duplicado

   
Vista:

Validar si hay duplicado

Publicado por Jorge Cervantes (23 intervenciones) el 13/10/2010 19:52:15
Favor si me pueden ayudar:
Tengo una tabla con varios campos pero el problema que tengo es en la columna A donde tengo item
1
2
3
4
5
6
7
8
9
Pero a veces no se lleva la secuencia porque es una suma automatica +a1+1
pero a veces los operadores de esta tabla borran la formula y colocan manuelmente los numeros como puedo hacer la busqueda en la columna para ver si hay duplicados y que no sean correalativos y que me avice donde esta el error y corregirlo automaticamente mediante macros

Gracias por el aporte
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Validar si hay duplicado

Publicado por Luis Fernando Giraldo (805 intervenciones) el 15/10/2010 06:25:50
Con un formato condicional sobre el rango requerido puedes detectar cuales valores estan repetidos usando para el formato condicional por ejemplo la función CONTAR.SI de la forma siguiente:

=CONTAR.SI($A$1:$D$12;A1)>1

Luego puedes colocar una macro de evento como la siguiente para que cada celda que señales de la columna A sea igual al valor de la celda superior + 1

Private Sub Worksheet_Selectionchange(ByVal Target As Range)
If Target.Column = 1 Then ActiveCell.FormulaR1C1 = "=R[-1]C+1"
End Sub

Recuerda que la macros de evento no van en lo módulos sino sobre la hoja correspondiente.

Cordial saludo desde Pereira Colombia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar