Excel - Pregunta facil (para un experto)

   
Vista:

Pregunta facil (para un experto)

Publicado por pepelu (3 intervenciones) el 04/02/2011 17:54:31
Buenas tardes, de verdad que no hubiera escrito en este foro si no hubiese buscado por google y por otras fuentes una respuesta a mi duda, duda que seguro sea una tontería pero que me está quebrando la cabeza.
Como ejemplo pongo el siguiente:

A B C D E F
1 1 1 2
2 1 2 2
3 1 1 1
4 2 1 2
5 1 2 1

Bien, esos serían los datos introducidos.
Ahora, para tema estadístico, necesito recontarlos en base a unos criterios (condiciones).
Por ejemplo, quiero que en F1 se me cuenten todos los "1" que hay desde A1 hasta A5 que cumplan la condición de que en la columna C tengan el valor "2"; por lo que el resultado de la operación requerida debería ser 2 (únicamente se da esa condición en la fila 1 y 2).
Lo he intentado con la condicional CONTAR.SI pero no se cómo añadir a la fórmula las otras condiciones (que el valor de la columna sea 2)....
En fin, a ver si algún máquina del excel me puede echar una mano.....
Gracias!!!!!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Pregunta facil (para un experto)

Publicado por jcs (494 intervenciones) el 04/02/2011 20:36:36
Muy buenas,

mira a ver si te sirve esto:

=SUMAPRODUCTO((A1:A1000=1)*(C1:C1000=2))

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Pregunta facil (para un experto)

Publicado por Luis Fernando Giraldo (805 intervenciones) el 06/02/2011 00:33:44
Similar a la ayuda de Jcs te cuento que si tienes Office 2003 tendras que usar SUMAPRODUCTO pero si tienes Office 2007 tambien lo podras hacer con:

=CONTAR.SI.CONJUNTO(A1:A1000;1;C1:C1000;2)

Cordial saludo desde Pereira Colombia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Pregunta facil (para un experto)

Publicado por pepelu (3 intervenciones) el 06/02/2011 12:42:47
Gracias por vuestras respuestas, al final usé la opción SUMAPRODUCTO ya que uso la hoja con excel 2003 en un ordenador y 2007 en otro y busco la máxima compatibilidad.
Resolviendo mi duda me ha surgido otra del mismo estilo:
..........A............B...........C.............D...............E
1 1 1 2 1 01/01/2011
2 2 1 1 2 05/01/2011
3 1 2 1 1 09/01/2011
4 1 1 1 1 20/01/2011

¿Podría "filtar" bien en otra hoja del mismo libro o bien en un archivo diferente los datos introducidos en base a unas condiciones y fechas?
Por ejemplo, me gustaría filtar en dos quincenas del 01/01/2011 al 15/01/2011 y del 16/01/2011 al 31/01/2011 por un lado y que dentro de cada quincena aparezcan únicamente las filas en las que se cumplan esta condición, en primer lugar que de A1:A4 sea "1" y que de C1:C4 sea 1.
Mas o menos esa es mi idea la cual, con vuestras respuestas, seguro se verá alimentada y ampliada.
Muchas gracias, señores!!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Pregunta facil (para un experto)

Publicado por jcs (494 intervenciones) el 06/02/2011 20:03:07
Muy buenas,

lo que tienes que hacer es seguir usando comparadores. Así te podría quedar de la siguiente forma:

=SUMAPRODUCTO((A1:A4=1)*(C1:C4=1)*(E1:E4<FECHANUMERO("16/01/2011"))*(E1:E4>FECHANUMERO("01/01/2011")))

De todas formas, yo te sugeriría que las fechas con las que quieres comparar las pusieras en otras celdas. Por ejemplo si en G1 y H1 pones la fecha de inicio y fin de la quincena, respectivamente, te valdría esto:

=SUMAPRODUCTO(($A$1:$A$4=1)*($C$1:$C$4=1)*($E$1:$E$4<=H1)*($E$1:$E$4>=G1))

Esto último, te permititía ir agregando filas de fechas (quincenas), e ir copiando la fórmula anterior.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar