Excel - Buscar y contar celdas horizontales con valores

   
Vista:

Buscar y contar celdas horizontales con valores

Publicado por Catita (14 intervenciones) el 05/05/2011 01:16:53
Estimados.

Necesito buscar un nombre en una matriz, y si lo encuentra que cuente en forma horizontal cuantas celdas con valores hay, y si encuentra un espacio en blanco que no cuente mas.

Estas son las tablas que tengo y estan en una misma HOJA

Matriz.
---------A------------------B-------------C------------D
1--OPERARIO--------RUTA1----RUTA2-----RUTA3
2--Jose------------------1234------1200--------1245
3--Carmen-------------1122------1133
4--Jorge----------------1351------1222---------1132
5--Manuel--------------1457


Nombre a buscar
------A--------------------B--------------C-------------D
10--OPERARIO--TOTAL/RUTAS
11--Jose-------------------3
12--Manuel---------------1
13--Carmen--------------2


Por ejemplo: Si Jose(A11) se encuentra en la matriz(A2), entonces cuantas rutas tiene y lo copie en B11. Asi sucesivamente

Atentamente.

Catita
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Buscar y contar celdas horizontales con valores

Publicado por Armando (126 intervenciones) el 05/05/2011 02:40:26
iNTENTA CON ESTO:
=SUMAPRODUCTO(--(A$2:A$5=A8)*(B$2:D$5>0))
En A8 el primer nombre y copia hacia abajo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Buscar y contar celdas horizontales con valores

Publicado por Catita (14 intervenciones) el 05/05/2011 15:19:00
Resulto perfecto, Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Buscar y contar celdas horizontales con valores

Publicado por Armando (126 intervenciones) el 05/05/2011 22:36:48
Gracias por avisar
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar