Excel - Ordenar una columna posicion de goleadores

   
Vista:

Ordenar una columna posicion de goleadores

Publicado por CHECHA checha_st@hotmail.com (1 intervención) el 20/05/2011 05:18:36
hola, a todos..bueno mi pregunta y duda es la siguiente:
en una hoja de excel 2007 en un deber del colegio me pidieron que hiciera una tabla para posicionar a los equipos goleadores de una liga, en total 10 jugadores:
ahora lo que deceo hacer es lo siguiente:
al momento de colocar los respectivos numeros de goles en la fila B2 asta B11. quiero que en la columna de C2 asta C11 me coloque la posicion de cada goleador, por ejemplo
si en la columna B de goles coloco:
b2: 9
b3: 10
b4: 1
b5: 4
entonces en la columna de C (posiciones) me muestre segun la fila de goles lo siguiente:
(GOLES) B2: 9 -----(POSICION) C2:SEGUNDO
(GOLES) B3: 10 -----(POSICION) C3:PRIMERO
(GOLES) B4: 1 -----(POSICION) C4:CUARTO
(GOLES) B4: 4 -----(POSICION) C5:TERCERO
y asi sucesivamente asta 10 posiciones solo quiero que la fila de C (posiciones) SE MODIFIQUE y no las otras dos.
y si encaso ubiese un empate entre dos o tres goleadores que me muestre EMPATE en la fila C y que mantengan su posicion dependiendo de los goles:
por el momento e realizado esta formula: porfavor espero sus opiniones y ayuda, si en caso no estuviese bien la formula que estoy utilizando porfavor aganmelo saber...esta formula es para la primer fila osea C2..para C3,C4 cambia el orden:
=SI(Y(B2>B3,B2>B4),"PRIMER LUGAR",SI(Y(B2<B3,B2>B4,),"SEGUNDO",SI(Y(B2<B4,B2>B3),"SEGUNDO",SI(Y(B2<B3,B2<B4,),"TERCER LUGAR"))))
solo e probado para tres,lo que me falta es si hay algun equipo goleador con igual cantidad de goles..
de antemano muchisimas gracias por su ayuda....bndiciones


---------------------------------------------
! !____A_______!_______B______!______C______!
!1 !__EQUIPOS___ ___GOLES______ _POSICIONES____
!2 !__R.MADRID__ ______________ _______________
!3 !_CHELSEA___ _______ _______ _______________
!4 !_M.UNITED___ ______________ _______________
!5 !_M.CITY_____ ______________ _______________
!6 !_zARAGOZA___ ______________ _______________
!7 !_BARCELONA__ ______________ _______________
!8 !_VALENCIA___ ______________ _______________
!9 !_ARSENAL____ ______________ _______________
!10!_A.D MADRID_ ______________ _______________
!11!_A-D BILBAO_ ______________ _______________
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Ordenar una columna posicion de goleadores

Publicado por jcs (494 intervenciones) el 20/05/2011 09:27:23
Muy buenas,

de antemano te digo dos cosas:
- la solución que propones de utilizar la función SI, es inviable en el momento en que aumenta el número de casos a comparar. Aunque se pudiera, que no se puede, comparar así 10 casos te llevaría a fórmulas enormes.
- yo no he encontrado una solución para resolverlo utilizando una sola celda.

Lo que te propongo es utilizar dos celdas:
En C:
=JERARQUIA(B2;$B$2:$B$11)
En D
=SI(CONTAR.SI($C$2:$C$11;C2)>1;C2 & "º empate";C2 & "º")

Esto te va a dar el resultado en número de la forma 1º, 2º empate, etc.
Si quieres que salga letra en vez de número, crea una tabla de la forma
1 PRIMERO
2 SEGUNDO
...
y utilizas BUSCARV.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar