Excel - ordenacion automatica

   
Vista:

ordenacion automatica

Publicado por JOSE MANUEL (5 intervenciones) el 25/09/2011 21:44:08
tengo una tabla con cuatro columnas (a, b,c,d) y cinco filas.
las columnas tienen celdas vacias inicialmente segun el siguiente ejemplo:
a b c d
4 2 13
7 1 9 11
3 8
6
5 12 10

Quiero que en otra hoja aparezcan ordenadas de menor a mayor automaticamente quedando las celdas vacias en las ultimas filas; es decir, de la siguiente manera:

a b c d
3 1 2 8
7 4 9 10
5 6 12 11
13

muchas gracias por vuestra ayuda
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana

ordenacion automatica

Publicado por Antoni Masana (264 intervenciones) el 26/09/2011 13:39:40
¿Y la pregunta es ... ?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

ordenacion automatica

Publicado por JOSE MANUEL (5 intervenciones) el 26/09/2011 13:45:28
la pregunta es: como consigo que al introducir un numero en una casilla vacia o modifique un valor de los existentes en la hoja inicial (tabla primera), me aparezca en una segunda tabla u hoja todos los datos ordenados, sin celdas vacias y que no tenga que hacerlo columna por columna tal y como refñlejaba en la segunda tabla del ejemplo.
gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

ordenacion automatica

Publicado por Raziel (243 intervenciones) el 01/10/2011 19:15:56
Si tus datos estan en A1:A5, pega la siguiente formula en D1:D5

=SI.ERROR(K.ESIMO.MENOR($A$1:$A$5,FILA()),"")

La funcion FILA sin argumentos arroja como resultado el numero de la fila en que se esta calculando, en nuestro caso para D1 es 1, en D2 es 2, etc...

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar