Excel - trasponer rangos

   
Vista:

trasponer rangos

Publicado por jose joorse@speedy.com.pe (1 intervención) el 26/09/2011 23:49:26
Buenas me dijeron que esto podia ser con la funcion DESREF y quisiera ayuda.
Lo que deseo es trasponer filas en columnas pero de 4 en 4 por ejemplo en la hoja de excel tengo:
Gil, Enrique
Avenida Pino 111
Alcorcón, Madrid
(555) 128-549
Cornejo, Cecilia
Calle Roble 222
Ibi, Alicante
(555) 238-1845
Bermejo, Antonio
Avenida Cereza 333
Illescas, Toledo
(555) 581-4914

Y quiero trasponer a:
Gil, Enrique Avenida Pino 111 Alcorcón, Madrid (555) 128-549
Cornejo, Cecilia Calle Roble 222 Ibi, Alicante (555) 238-1845
Bermejo, Antonio Avenida Cereza 333 Illescas, Toledo (555) 581-4914
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

trasponer rangos

Publicado por Raziel (243 intervenciones) el 01/10/2011 18:46:23
Ok, pensando que tu info se encuenta en la columna A1 y que esta acomoda mas o menos asi: Nombre, Direccion, Ciudad, Telefono y de vuelta se repite... la formula podria quedar asi:

=SI(FILA()<>1,INDIRECTO("A"&((FILA()-1)*4)+COLUMNA(A1)),INDIRECTO("A"&COLUMNA(A1)))

Esta misma formula la copias y la pegas en un rango contiguo que abarque 4 columnas, el resultado debe ser el esperado, en tu misma pregunta sugieres el uso de una funcion en especifico, como puedes observar yo no la ocupe, pero para nada significa que no se pueda hacer con ella solo que no me senti tan comodo utilizandola tambien significa un poco que mi inteligencia no alcanzo, jejejeje, en fin, espero haberte ayudado.
Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar